E-Business Suite Technology Stack Roadmap (April 2010) Now Available

Keeping up with our E-Business Suite technology stack roadmap can be challenging.  Regular readers of this blog know that we certify new combinations and versions of Oracle products with the E-Business Suite every few weeks.  We also update our certification plans and roadmap as new third-party products like Microsoft Office 2010 and Firefox are announced or released.  Complicating matters further, various Oracle products leave Premier Support or are superceded by more-recent versions.

This constant state of change means that any static representation of our roadmap is really a snapshot in time, and a snapshot that might begin to yellow and fade fairly quickly.  With that caveat in mind, here's this month's snapshot that I presented at the OAUG/Collaborate 2010 conference in Las Vegas last week:

Snapshot of E-Business Suite release roadmap including 11i and 12 as of April 2010

What's in the latest roadmap?
  • Comparisons of support categories (Premier, Extended, Sustaining)
  • Summaries of the latest database, Fusion Middleware, and E-Business Suite Lifetime Support Policies
  • Desktop Client certifications (browsers, JREs, operating systems)
  • Database Tier certifications
  • Application Server Tier certifications
  • External Integrations certifications
  • Security-Related certifications
  • "Other Cool Stuff" -- virtualization, clouds
How should I use this roadmap?
  1. Check the support status of your currently deployed techstack component versions
  2. Plan your upgrades to the next certified level
  3. Build a business case for switching from older technology to the latest technology (e.g. switching from Discoverer to Oracle Business Intelligence Enterprise Edition+)
  4. Seek clarification on open questions
Related Articles

The preceding is intended to outline our general product direction.  It is intended for information purposes only, and may not be incorporated into any contract.   It is not a commitment to deliver any material, code, or functionality, and should not be relied upon in making purchasing decision.  The development, release, and timing of any features or functionality described for Oracle's products remains at the sole discretion of Oracle.

Comments:

Regarding R12 roadmap.

Any plans for an R12.2 release? I see we have a "?" after 12.1. Am curious to see if R12.2 will be released, which will bring it's own Premier Support timelines.

It's tough to sell an R12.1 implementation that enters Extended Support in 2014.

Posted by Tim Monday on August 04, 2010 at 06:42 AM PDT #

Hello, Tim,

Yes, we're working on 12.2 right now (overlapping our 12.1.3 release activities). This will be a major release; stay tuned for more details.

Regards,
Steven

Posted by Steven Chan on August 04, 2010 at 08:17 AM PDT #

Hi Steven,

we are right now on 12.1.3 and the functional team needs the patch 11779376 that is on codeline C

Description Contract Lifecycle Management - Rollup Patch 2 (RUP2)
Product Purchasing
Release Applications R12
Compatible With R12.PO.C

As we are on codeline B (Release 21.1.x) we need to upgrade to 12.2.x but is not released yet.

Any information about the dates to be released?

Best regards,
José Antonio

Posted by guest on July 31, 2011 at 05:52 PM PDT #

Hi, Jose,

EBS Support should not be advising any customers to apply 12.2 patches. If you provide me with your Service Request number, I'll clear that up with Support.

Oracle's Revenue Recognition rules prohibit us from discussing certification and release dates, but you're welcome to monitor or subscribe to this blog for updates, which I'll post as soon as soon as they're available.

Regards,
Steven

Posted by Steven Chan on August 01, 2011 at 03:18 AM PDT #

Hi Steven,

at SR 3-3985960981 EBS Support indicated us to apply patch 11779376:R12.PO.C.(see update 19 July 2011 11:06:24 GMT+02:00).

applying patch 11779376 we get the following errors:

AutoPatch error:
-----------------------------------------------------------------------
This patch is not compatible with your current codelines.

This patch is compatible with: entity 'pon' - codeline 'R12.PON.C'.
Your current on-site codeline for the entity 'pon' is: 'R12.PON.B'.

You should not apply this patch.

Apply an equivalent patch that is compatible with your
current codelines instead.
------------------------------------------------------------------------

according with oracle's documentation:
------------------------------------------------------------------------
"In Release 12, Oracle E-Business Suite patches are grouped into codelines. A codeline begins with a point release (for example, Release 12.0) consisting of a unique set of product features, and progresses to include all the patches created to maintain that point release. The initial Release 12.0 point release introduced codeline A. Additional point releases introduce new codelines, each identified by a unique letter. For example, Release 12.1 introduced codeline B, and Release 12.2 is expected to introduce codeline C."
------------------------------------------------------------------------

right now we don't have any answer about what to do and how to fix it.

Best regards and thanks for your interest.
José Antonio Ruiz

Posted by José Antonio on August 01, 2011 at 08:33 PM PDT #

Hello, Jose,

Thanks for your SR number. Once again, Support shouldn't be advising customers to apply patches for a release that isn't available yet.

I've advised the Support Engineer on that SR to request a backport for the required fix to the EBS 12.1 codeline that you're on right now.

Regards,
Steven

Posted by Steven Chan on August 02, 2011 at 03:08 AM PDT #

Hi Steven,

thanks you very much for the help, it's a pleasure to follow the blog.

Best regards and again thanks you
José Antonio Ruiz

Posted by José Antonio on August 02, 2011 at 03:59 AM PDT #

Hi Steven,

Thanks in advance,

Very useful info. However, I have one question:
If the customer is already on 12.0.4 or 12.0.6, can they directly upgrade to 12.1.3 or, a) for 12.0.4 they first go to 12.0.6 then to 12.1.1 and then apply 12.1.3 RUP; b) for 12.0.6, they first have to go to 12.1.1 and then apply the 12.1.3 RUP?

Please advise,

Best Regards,
Vasu

Posted by guest on March 20, 2012 at 06:50 PM PDT #

Vasu,

Thank you for the inquiry.

The R12.1.3 Release Update Pack may only be applied on top of a R12.1.1 environment.

For a customer that is on R12.0.4, the upgrade path is as follows: R12.0.4 -> R12.1.1 -> R12.1.3

Details regarding the upgrade path may be found in My Oracle Support Note 1299150.1

Regards,
~ep

Posted by guest on March 22, 2012 at 06:56 AM PDT #

Post a Comment:
  • HTML Syntax: NOT allowed
About

Search

Categories
Archives
« April 2015
SunMonTueWedThuFriSat
   
1
3
4
5
7
9
10
11
12
13
17
18
19
20
23
25
26
27
28
29
30
  
       
Today