Oracle VM Virtual Appliances Available for E-Business Suite Release 12.2.3

Oracle VM Virtual Appliances for E-Business Suite Release 12.2.3 are now available from the Oracle Software Delivery Cloud at this location:

 These virtual appliances can be imported into Oracle VM Manager to deploy E-Business Suite Linux 64-bit environments on compatible server-class machines running Oracle VM Server.  Alternatively, they can be imported into Oracle VM VirtualBox to create virtual machines on a desktop PC or laptop.

The virtual appliances deliver the full software stack, including the Oracle Linux 6.5 operating system, Oracle E-Business Suite, and additional required technology components.

The available Oracle E-Business Suite Release 12.2.3 virtual appliances are:

  1. Single Node VISION Demo
  2. VISION Demo Database Tier
  3. Production (PROD) Database Tier
  4. Application Tier
  5. Sparse Application Tier

These appliances can be used to support the following scenarios:

  • Single node E-Business Suite 12.2.3 installation: Choose the single node VISION Demo virtual appliance (Option 1 above) to create a unified virtual machine with the EBS 12.2.3 database and application tiers.
  • Multi-node E-Business Suite 12.2.3 installation: Create a multi-node system using the database virtual appliance of choice (either VISION or PROD) and the application tier virtual appliance. That is, Option 2 or 3 above, followed by Option 4.  You can then add secondary application tiers using Option 5.
  • Operating system-only installation (Oracle Linux 6.5): The sparse application tier virtual appliance (Option 5) includes the necessary operating system packages, kernel parameter settings, and users (oracle and applmgr) required to install Oracle E-Business Suite, providing benefit for customers who plan to use Rapid Install for their 12.1.3 or 12.2.3 installation.
References

Related Articles

Comments:

Hi Mates,

I was looking this information from longtime, as I required this environment for OBIA purpose..

Thanks for sharing

Regards
Kashif M
www.mkashu.blogspot.com

Posted by kashif on March 08, 2014 at 10:58 AM PST #

Awesome stuff. The Virtualbox import option is a welcome and amazing addition to the EBS VM template family. Single-node 12.2.3 Vision instance with less than 10 minutes of typing? Yes *please*! That's about as hands-free as one can hope for this process to get.

BTW, I made a few minor changes to the assemble.sh script to get it to work on OS X. Is there a way that I could share the adjustments for the benefit of others? Since it's My Oracle Support-hosted content, I assume that just throwing it out on github is not a good idea. ;)

Posted by John Piwowar on March 10, 2014 at 08:04 PM PDT #

Thanks John -- glad these are making a difference. And yes, go ahead and share the assemble script for OS X with us.

Posted by guest on March 11, 2014 at 11:28 AM PDT #

Thank you very much for directly supporting the VirtualBox. It's very easy to test this on a Laptop/Desktop environment now. VirtualBox is my favorite VM environment.
Thanks again.

Posted by guest on March 13, 2014 at 11:54 AM PDT #

I have downloaded the Single-node template for use with VirtualBox.
I logged in as root, changed all passwords as prompted and picked Vision database option.
I rebooted and logged in as Oracle but database and app was not started automatically.
When I try to start the Vision database using /u01/install/VISION/scripts/startvisiondb.sh, I get an error. It is not able to get to addbctl.sh and addlnctl.sh.
This script is looking for the file in /u01/install/VISION/11.2.0/appsutil/scripts/VISION_localhost
where as the script is in
/u01/install/VISION/11.2.0/appsutil/scripts/VISION_ebs

When I tried to run the script from this location
it did try to start the database but gave an ORA-00119, ORA-00130 error.

Is there an environment file I need to set or run?
I think I am missing a step. Can somebody help?

Posted by guest on March 13, 2014 at 03:28 PM PDT #

Hello, Guest,

I'm sorry to hear that you've encountered an issue with this.

We can provide general conceptual guidance here, but I'm afraid that this blog isn't the best place to get technical support for specific issues like the one that you're working through.

Your best bet would be to log a formal Service Request via My Oracle Support (formerly Metalink) to get one of our specialists engaged.

Regards,
Steven

Posted by Steven Chan on March 13, 2014 at 03:54 PM PDT #

Hi Guest with the single-node install problem,

I agree w/ Steven that this is not good forum for troubleshooting/tech support. In addition to My Oracle Support, may I also recommend the OTN forums, specifically the EBS-themed ones?

Since this is not a support forum, and I don't want to start a bad trend, I won't follow up further. But I will use this comment give one "free hint" :)

You can't just start the Vision db immediately after deploying the template. You need to:
1) configure the network interface (/u01/install/scripts/configdhcp.sh or configstatic.sh)
2) configure the database tier (/u01/install/VISION/scripts/visiondbconfig.sh)
3) configure the apps tier (/u01/install/VISION/scripts/visionappsconfig.sh)

You'll find more detail in Note 1620448.1, the first item in the reference list for this blog post.

Posted by John Piwowar on March 13, 2014 at 08:36 PM PDT #

Guest,

I too got the same error.
Here is how I resolve the issue and started the services:
1. Change the hostname of the linux server to ebs.example.com
Ref: http://www.cyberciti.biz/faq/linux-change-hostname/
2. Connect to oracle and run the scripts - first, startvisiondb.sh and then startvisionapps.sh.

I am able to start the DB and listener successfully. But, the startvisionapps.sh is taking long time to execute.

I saw scripts in /u01/scripts. But, they are giving errors about "fi". I will check them later.

I hope this helps.
Rama Nalam

Posted by guest on March 13, 2014 at 09:44 PM PDT #

Hi, I am trying to execute assemble.sh script using Cygwin and is failing with at the md5sum. Is Cygwin appropriate to run the assemble script?

Thanks
BV

Posted by BV2008 on March 15, 2014 at 02:56 PM PDT #

Hi Steve,

Are the VM Templates still available to all?

I couldnt find the option in the LOV.

Posted by guest on April 03, 2014 at 08:00 AM PDT #

The network configuration is automatically done using a DHCP setup during the boot of the VM. However there is a "then" missing for the if statement. You can edit the configdhcp.sh and configstatic.sh to fix this issue.

if [ -f /root/.passchanged ];

then<----------------------------------------------------------------------------- was missing which caused the script to not config the network
rm -rf /root/.passchanged
fi

How do u fix the problem

1. Edit the /u01/install/scripts/configdhcp.sh and modify the script as described above. Also modify the configstatic.sh if you are planning to use a static IP. The hostname is automatically configured as ebs.example.com for the given IP.

2. Execute the /u01/install/scripts/cleanup.sh . On next boot it will automatically configure the required network.

This issue is being tracked and the updated scripts will be available via a patch.

This issue is only seen with the single node vision template.

Posted by Noby Joseph on April 11, 2014 at 08:15 PM PDT #

We have released a patch to address the issue reported with the appliance boot scripts not configuring the network on the single tier Vision VM appliance. See the Known issue section of MOS Document 1620448.1 to apply the fix.

Posted by Noby Joseph on April 15, 2014 at 10:19 AM PDT #

BV2008 , Are you using the md5sum shipped with Cygwin ? We haven't tested the assemble script on non-unix platforms. if the rest of the script work on cygwin and if it is just the md5sum check that fails, it could be an issue with the md5sum utility. You can comment the md5sum check if u think that the downloaded media did not loose its integrity.

Posted by Noby Joseph on April 15, 2014 at 10:24 AM PDT #

This template Oracle-E-Business-Suite-12.2.3-VISION-INSTALL.ova (SINGLE VISION) has many issues . Here is the ones were identified sofar :

1. MD5sum check is incorrect so the script fails every time during assembly even if files are Ok . tested in windows (CYGWIN)
Workaround : comment out MD5check in shell script and use third party program to calculate if needed.

2. Problem with configdhcp.sh and configstatic.sh . This is already discussed in this thread.

3. startvisionapps.sh has couple of syntax errors

4. VISION_ebs.env file won't run (fs1 location) because of adovars reference is wrong) and APPSVISION_{HOST_NAME}.env useless because it's created (during configuration) under fs2 location and every time you run startvisionapps.sh it complains about patch mode has to be specified.

Conclusion: this template is not ready for deployment with custom host name/domain.

Thank you,

Posted by guest on May 05, 2014 at 05:21 PM PDT #

Hello Guest,

Sorry to hear that you are having trouble with the template. The template is fully virtualized which means that you can bring up the DB and the application with a virtual hostname called ebs.example.com without any re-configuration.

Should you require a re-configuration, we have also provided scripts for it. Check out the deployment guide.

Basically you will have to shutdown all the services and execute the re-configuration script. You may need to cleanup the following directories before executing the reconfig script

1. fs1/FMW_Home
2. fs2/FMW_Home
3. fs1/inst
4. fs2/inst
5. /u01/install/oraInventory/*

It works. We have tested it. You can configure it with any hostname you like.

Posted by Noby M Joseph on May 12, 2014 at 08:27 PM PDT #

Hi,

Can we set up the ISG using this template(first virtualbox machine)? If so, is it possible to install weblogic/SOA in a second Virtualbox machine and integrate the ISG with the template(from the first Virtual machine)?

Thanks,
Eddie

Posted by eddie on May 13, 2014 at 05:47 PM PDT #

Eddie-
There are no differences in ISG support if one installs using virtual media (appliances or templates) or the Rapid Install. Here is the document regarding setting up ISG with 12.2. If you have further questions, please log a service request.

Installing Oracle E-Business Suite Integrated SOA Gateway, Release 12.2(Doc ID 1311068.1)

Thanks!
Terri

Posted by terri noyes on May 14, 2014 at 08:48 AM PDT #

Hi,

I installed the Template(SINGLE VISION)and everything seems to work fine, but we are not able to start the "Background Engine". Does anyone know which steps to follow to bring it up?

Thanks,
Eddie

Posted by eddie on May 22, 2014 at 03:33 PM PDT #

Eddie-
What do you mean by background engine?

Please clarify if you are using VirtualBox (not VM Manager), and that you imported the appliance itself. Did you start up the database tier processes and the application tier processes?

-Terri

-Terri

Posted by Terri Noyes on May 23, 2014 at 06:01 AM PDT #

Hi,

I have downloaded Virtual Box Templates and installed Since node VISION instance. Everything seems to be ok except opening an applet. I believe, by default jre 1.6 build 27 comes up with VISION. After various attempts, I am still unable to launch forms when clicked on any responsibility.

My OS is Windows 8.1 Professional 64 bit..tried on IE10, Fireforx & Chrome....nothing works out. Appreciate, if you could let me know how to proceed further.

Rgrds,
Ata

Posted by Ata on June 26, 2014 at 12:04 AM PDT #

Hi, Ata,

I'm sorry to hear that you've encountered an issue with this.

We can provide general conceptual guidance here, but I'm afraid that this blog isn't the best place to get technical support for specific issues like the one that you're working through.

Your best bet would be to log a formal Service Request via My Oracle Support (formerly Metalink) to get one of our specialists engaged.

Please feel free to forward your Service Request number to me if it gets stuck in the support process for some reason.

Regards,
Steven

Posted by Steven Chan on June 26, 2014 at 08:51 AM PDT #

We has successfully installed the Oracle E-Business Suite Release 12.2.3 virtual appliances Single Node VISION Demo in OracleVM. But we are not able to see some of the modules mentioned below:-
1. Oder Management (OM)
2. Trading Community Architecture (TCA)
3. Interface Table of AR
4. Inventory (INV)
5. General Ledger(GL)
6. FND
7. FND Application Object Lib

Please help us with the steps required to get these modules installed.

Posted by Manish on July 02, 2014 at 10:06 AM PDT #

Hi, Manish,

I'm sorry to hear that you've encountered an issue with this.

We can provide general conceptual guidance here, but I'm afraid that this blog isn't the best place to get technical support for specific issues like the one that you're working through.

Your best bet would be to log a formal Service Request via My Oracle Support (formerly Metalink) to get one of our specialists engaged.

Regards,
Steven

Posted by Steven Chan on July 02, 2014 at 10:13 AM PDT #

Hello!

I am quite stuck into setting up the Single Node VM. This is what I have done on my laptop:

1. Setup Windows 2012 Server for DNS, AD
2. Created example.com domain
3. Imported Single node Vision template appliance downloaded from edelivery
4. Changed passwords for root, oracle and applmgr
5. Logged in as root, executed configstatic.sh and supplied host name as ebs.example.com. I can ping between the ad server and the ebs host in both directions
6. Executed visiondbconfig.sh from /u01/install/VISION/scripts. Database is configured and script ends with information of the database environment including URL
NOTE: When I switch to oracle user after this, I don't find ORACLE_HOME environment variable set.
7. Execute visionappsconfig.sh as root user. Supply the inputs for dbhost, domain, port and SID. The scrip stops execution sending message as below:
Are you connecting to a RAC instance (y/n): n

Unable to connect to the database VIS1223 on ebs
Please ensure that the host ebs is allowed to connect to the Oracle E-Business Suite running on ebs

Press any key to continue..

The script then stops executing.

I have been trying to fix this for almost a week now but to no avail. Any pointers to the mistake I am doing will be great help.

Regards,
Girish

Posted by guest on July 27, 2014 at 12:29 AM PDT #

Hello, Girish,

I'm sorry to hear that you've encountered an issue with this.

We can provide general conceptual guidance here, but I'm afraid that this blog isn't the best place to get technical support for specific issues like the one that you're working through.

Your best bet would be to log a formal Service Request via My Oracle Support (formerly Metalink) to get one of our specialists engaged.

Regards,
Steven

Posted by Steven Chan on July 28, 2014 at 01:25 PM PDT #

Hi Steven,

Thanks for a prompt response. I agree with you that this is not a correct place to get technical support. I saw that on previous comments of other's, too.

Good news is that after I reimported the appliance, I was able to set up the VM. Barring the code fix in the install script - and setting up oracle user's profile in .bash_profile, everything else went OK and I am here with a running EBS system with VISION on VM.

I am not very sure that I really needed to fix oracle user's profile but just for the sake of having it in place and to minimize waste of time, I did it.

Thanking you once again.

Regards,
Girish

Posted by Giridh on July 28, 2014 at 11:19 PM PDT #

There is a lot of pointing to My Oracle Support documents for the Deployment Guide. I know of at least one developer (me) who is between projects and has already removed the previous Support ID from his profile. Because of that, I can't get to the guide. The best I can do is the Release 12.1.1 guide at http://docs.oracle.com/cd/E16538_01/ovm/html/docset.html. Is there any chance that other releases could have their Deployment Guides put somewhere that you only need access to OTN, or is there some reason for restricting that doc to people with a current Support ID?

Thanks,
JH

Posted by JH on August 05, 2014 at 11:15 AM PDT #

Hello, JH,

Unfortunately, My Oracle Support is the official source of companion documentation (Notes) for our core guides. We are not permitted to distribute Notes outside of My Oracle Support.

Regards,
Steven

Posted by Steven Chan on August 05, 2014 at 03:38 PM PDT #

Hello

Can you an instruction set for an installation straight into windows 7 please for 12.2?

Posted by Chuose on August 19, 2014 at 06:27 PM PDT #

Hi
I am trying to install the ebs virtual appliance on VirtualBox on my MacBook but a bit confused by all the different options (e.g. VM appliance or VM templates). All I want is as simple and straightforward install of ebs as possible (12.2.2 or 12.2.3) for study/development purpose.

I find the Oracle Docs not that easy to follow but if someone can list the steps or point to a site that would be greatly appreciated. Also John can you please share the small change you made to the assemble.sh script to get this working on a Mac.

Many thanks

Posted by guest on September 29, 2014 at 04:07 AM PDT #

I just downloaded assembly files for single node VM. However, the necessary assembly.sh file seems to be part of support document#1904928.1 which is available to only customers. Am I missing something?

I am employed with a compnay that has huge number of Oracle licenses (db and EBS) and yet I do not have access to my oracle support as those who have those with them do not share support information with us. If the files are provided for download, why not the assembly script?

Posted by guest on October 30, 2014 at 11:22 AM PDT #

To deploy this appliance you would follow the instructions in Oracle VM Virtual Appliances for Oracle E-Business Suite Deployment Guide, Release 12.2.3 (My Oracle Support Knowledge Document 1620448.1). The script is also attached to that document. So, access to MOS is essential.

Posted by Terri Noyes on October 30, 2014 at 02:34 PM PDT #

Having downloads available and essential scripts not. I would appreciate if the same is mentioned in readme file or any place so that it catches attention and the user does not end up downloading files which he cannot use without MOS.

In My case, my organisation does have MOS but the team has create a monopoly over it and it feels being a beggar for us to asking them for MOS info.

I still respect your policies and appreciate whatever material is made available.

Posted by Girish on October 30, 2014 at 09:57 PM PDT #

To assemble the downloaded files you do not need the script. Script is provided for ease of assembling the archive file. All you need to do is

1. unzip the media pack files( zip files)

2. cat file.0 file.1 file.2 > file you want

That is your final OVA that need to be imported to the VirtualBox or OVM.

Posted by Noby Joseph on October 31, 2014 at 01:26 PM PDT #

When Installing EBS 12.2. Vision on a Mac must one first either install a Bootcamp Partition with Linux or alternatively Install VM Software like Parallels and install Linux on the Virtual Machine? I wasn't clear about this step or if Oracle VM Appliance Tools can be used natively in MAC OS negating the need for 3rd Party VM Software....

Posted by Justin Greene on November 06, 2014 at 09:14 AM PST #

Justin-
There is no need to install a Linux partition. Oracle VirtualBox runs natively on the Mac, so you import the appliances into VirtualBox. The appliances bring in the Linux guest OS. Does this answer your question?
-Terri

Posted by Terri Noyes on November 06, 2014 at 09:25 AM PST #

Hi Terri,

Yes this is was exactly the clarity I needed. However, I don't seem to be able to get the downloaded ISO Image to be recognized, I think I will be in good shape once that's resolved. I will be troubleshooting that issue this morning (PST). Hoping for favorable results.

Thank you so much for the quick turnaround to my inquiry

Posted by Justin Greene on November 07, 2014 at 07:00 AM PST #

Justin-
So, did you download all the zip files for the Single Node Vision install, unzip them, and concatenate them into a single ".ova"?
-Terri

Posted by Terri Noyes on November 07, 2014 at 07:52 AM PST #

@Noby Joseph
I was frustrated since there were no instructions I was about to delete the downloaded files(countless downloads after md5 check sum failures) and just in time I stumbled across your post and I was able to merge files with cat command and successfully imported appliance

Posted by guest on November 08, 2014 at 10:47 AM PST #

Hi Terri,

Add your downloaded folder as a shared folder to another linux guest o/s or use any other linux live cd(or iso) ,unzip the files and merge(concatenate) the unzipped the files with cat command

Sam

P.S:-If you are on Mac I guess you can skip above steps ,just unzip zipped files into single folder and run cat command to merge multiple files to single file with ova extension(see Noby Joseph comment)

Posted by Sam on November 08, 2014 at 10:55 AM PST #

Hi Terri,

Finally, I was able to download all 15 Single Node Zip Files for 12.2.3 and they appeared to have auto compressed immediately after they downloaded successfully.

Can you provide some details on how to concatenate these files now that they have been progressed to this stage...? I am running this on a Mac Mini USING OS X 10.10 Yosemite. The challenge was the amount of time it took to download as there are no viable Download Managers for Safari that work on OS X 10.10

Anyway the needle is moving in the right direction and I hope get this environment up and moving pursuant to your help with the concatenation challenge I currently face. Here is an example of what the extracted file looks like in OS X 10.10 'Oracle-E-Business-Suite-12.2.3-VISION-INSTALL.ova.00'

Posted by Justin on November 08, 2014 at 03:17 PM PST #

Finally I was able to import appliance into Virtual box,didn't run any scripts,modified static address and additional adapter manually,pointing ebs.example.com to static ip address,db is up and working fine but middle tier all services running up without any errors except adadminsrvctl.sh exting with status 1 since I don't know default password for WLS.Can someone point out default password for WLS?.

Thanks
Sam

Posted by Sam on November 08, 2014 at 04:07 PM PST #

Hi Sam
Congrats ! May I ask what kind of machine you are using what action was taken to concatenate the multiple files into a single file. I am not clear in how to execute this task. I am using a MAC OS X 10.10

Posted by Justin on November 08, 2014 at 04:26 PM PST #

Finally I set up the system without running any scripts.I find only one minor annoyance i.e network configuration this system never detects existing or new network adapters(either host only and bridged network adapters)other than that this is truly plug in play appliance.

P.S:-Ignore my prior message asking for wls default password,after setting up I realized there is another scripts folder inside the vision directory.

Posted by Sam on November 08, 2014 at 06:11 PM PST #

Justin-
Open the terminal window on the Mac, and use the cat command, same as UNIX. For further questions, please open a service request. THX.
-Terri

Posted by Terri Noyes on November 10, 2014 at 05:25 AM PST #

As in the past I made some experience with tedious setup and patching procedures (12.1.1 -> 12.1.3) I was happy to find this time saving method. Here's my current progress:
1) Downloaded all zip archives for the single node VISION Demo
2) Used the assemble.sh script to create Oracle-E-Business-Suite-12.2.3-VISION-INSTALL.ova, worked after several attempts.
3) Extracted .vmdk and .ovf from the .ova file
4) Converted the .vmdk to .qcow2 (Instead of VirtualBox I'm using qemu-kvm on RHEL 6.5)
5) Created an xml file to start up the VM according to the information in the .ovf file
6) Started the VM with the RHEL compatible kernel, edited configstatic.sh.
7) Set up hostname and domain according to my network
8) Ran visiondbconfig.sh, worked - great, I could access the db from a remote VM.
9) Ran visionappsconfig.sh, started but failed after some time.
10) Stopped all services and cleaned up the folders according to Noby M Joseph's comment from May 12 2014.
11) Tried again, same result...
12) Reset the whole setup and used ebs.example.com as hostname. Now the application tier builds up correctly, looks like the comments made by the guest on May 05 2014 are correct.
I can now access the apps login url of ebs.example.com from another VM with an edited hosts file (puuh) but this is a workaround, no solution.

Does anyone know how to successfully create the application tier with a hostname other than ebs.example.com ???

Thank you in advance for your replies!
Martin

Posted by Martin Wieland on November 18, 2014 at 03:32 AM PST #

Hello martin,

Iam not sure what issue you are encountering. Please make sure the oraInventory and the FMW_Homes on both fs1 and fs2 are deleted before running the appsconfig.sh script. The script should accept whatever the hostname is set on the machine and do the configuration.

Thx

Posted by Noby Joseph on November 19, 2014 at 09:49 AM PST #

Hi Terri,

I was able to figure out how to concatenate the files into a single ova and import them into the machine successfully and set and enable network adapter to Host Only. However I understand that when I launch the machine I should expect to be prompted to supply new passwords however I encounter a prompt requesting the localhost login. I am unclear on what to enter here... Lost but I think I'm close. I am running this on a MAC Mini for what it's worth here...

Posted by Justin on November 19, 2014 at 09:23 PM PST #

Noby Joseph,
thank you. After running configstatic.sh and assuring that the hosts file is correct I ran visiondbconfig.sh, this worked perfect. Then I ran visionappsconfig.sh, this failed somewhere. First I tried to run visionappscleanup.sh and repeated the above process, same result. Then I deleted (rm -Rf) the folders you mentioned and tried to run visionappsconfig.sh again, this didn't work either. After running cleanup.sh the apps tier was created but with ebs.example.com.

Maybe it would be helpful for others too to know the correct sequence of the steps to create the apps tier with a custom hostname, there are a lot of config and cleanup scripts included.

Meanwhile I downloaded and installed the VM templates for EBS 12.2.4 as described in blogs.oracle.com/stevenChan/entry/e_business_suite_12_2. This worked like a charm although still with ebs.example.com. I can highly recommend these templates!

Thank you in advance for your reply.
Martin

Posted by Martin Wieland on November 20, 2014 at 07:33 AM PST #

Question:

Can I use the procedure 'How to change hostname for E-Business Suite Release 12 on single node (Doc ID 1277556.1)' to change the hostname in EBS 12.2.3 and 12.2.4?

Thank you in advance!
Martin

Posted by Martin Wieland on November 24, 2014 at 01:20 AM PST #

Hello,

I tried 1223 VM Templates with VB ver 2.3.6 and 2.3.8 on Dell Inspiron R15 with Windows 8.1, Intel i7-3632QM processor, 8gb ram, 1TB HDD, with 6gb ram, 500gb hdd allocated to VB. The installation failed with error : "failed to execute /u01/install/VISION/fs2/EBSapps/comn/clone/bin/adclone.pl".

Then I tried 1224 VM Templates with VB 2.3.20 on same laptop, this time it failed with error "failed to execute /u01/install/VISION/fs2/EBSapps/comn/clone/FMW/pasteBinary.sh".

I tried multiple times, always failed with same error. Please help.

Thanks
lata

Posted by guest on November 25, 2014 at 07:07 AM PST #

Hello Martin,

I know why this is happening. To reduce the size of the image we are not shipping a file called FMW_Home.jar on both fs1 and fs2 file systems. This cause the rewiring to fail with the new hostname. The recommended procedure is as follows.

1. Bring up your VM with the default ebs.example.com hostname.
2. Bring up the weblogic administration server from the current run edition file system.

$INST_TOP/admin/scripts/adadminsrvctl.sh start

3. Execute $INST_TOP/admin/scripts/adpreclone.pl appsTier . This will create the FMW_Home.jar

4. Bring up the weblogic administration server from the patch edition file system.

$INST_TOP/admin/scripts/adadminsrvctl.sh start forcepatchfs

5. Execute $INST_TOP/admin/script/adpreclone.pl appsTier for the fs2 file system which is your patch edition.

6.Shutdown any processes running

7. Now you use /u01/install/scripts/configstatic.sh or configdhcp.sh to set the new IP or hostname . You can modify the script to set the hostnames.

9.Run visiondbconfig.sh and visioapps.config.sh . Everything should work.

You do not have to use any other notes. The reason for failure is just because we are not shipping the FMW_Home.jar.

Posted by Noby Joseph on November 25, 2014 at 07:12 AM PST #

This is what (almost) worked for me (EBS 12.2.4, qemu-kvm, Centos 6.5) with Noby Joseph's help:
I strongly recommend to make a backup of the VM HDD and use enough RAM and CPU for the VM. I assigned 8192 MB and 4 CPU's. I'm also using an external HDD with enough free space.
1) Start the VM with the default ebs.example.com hostname
2) Log in as user oracle, applmgr didn't work for me due to permission issues
3) Source the runtime environment
/u01/install/VISION/source EBSapps.env
R
4) Execute $INST_TOP/admin/scripts/adadminsrvctl.sh start (script reported that the weblogic administration server was already up)
5) Execute $INST_TOP/admin/scripts/adpreclone.pl appsTier (this really takes some time)
6) Source the patch environment, same steps as in 3 but with P for the patch environment
7) Execute $INST_TOP/admin/scripts/adadminsrvctl.sh start forcepatchfs
8) Execute $INST_TOP/admin/scripts/adpreclone.pl appsTier
9) Stop APPS /u01/install/VISION/scripts/stopvisionapps.sh
10) Stop DB /u01/install/VISION/scripts/stopvisiondb.sh
11) As user root run /u01/install/scripts/configstatic.sh (or configdhcp.sh)
12) As user oracle run /u01/install/VISION/scripts/visiondbconfig.sh
13) As user oracle run /u01/install/VISION/scripts/visionappsconfig.sh (this really takes some time)

visionappsconfig.sh reported success for FS1. For FS2 I got a looping error 'Target System Port Pool [0-99] : RC-00201: Error: Not a valid port pool number'
I rebooted the server, EBS 12.2.4 started DB as well as APPS.

I guess that APPS is configured correctly on FS1 but not on FS2. If anyone has an idea how to fix that let me know.
Thank you!
Martin

Posted by Martin Wieland on November 26, 2014 at 04:37 AM PST #

Noby Joseph,
to resolve the issue with fs2 I again ran visionappsconfig.sh. For fs1 all went well, for fs2 it also looked good but at the end I got an error, SID is EBSDB hostname of my VM is ebs122.

ApplyAppsTier.log:

...Inside invokeOHSClone
Checking whether instance EBS_web_EBSDB_OHS1 is registered with domain...
RegisteredInstanceNames MBean attribute value is NULL
Instance EBS_web_EBSDB_OHS1 is not registered with Domain
/u01/install/VISION/fs2/FMW_Home/webtier/instances/EBS_web_EBSDB_OHS1 directory deleted successfully.

START: Instantiating the OHS Config.
Running /u01/install/VISION/fs2/FMW_Home/webtier/perl/bin/perl...
Script Executed in 21325 milliseconds, returning status 255
ERROR: Script failed, exit code 255

cfgCloneInstance.log:

...Modifying T2P plan is successfull

###################################################
Applying ohs<timestamp>.jar as per T2P moveplan.xml
###################################################

Apply clone ran successfully

OHS EBS_web_EBSDB shutdown succcessfully

#####################################
Generating apps.conf for cloneohsconfig
######################################
apps.conf generation faild. EBS won't work as expected
txkSetOHSConfig.pl is exiting with ERROR

Can this be savely ignored??
Martin

Posted by Martin Wieland on November 27, 2014 at 07:50 AM PST #

I'm running into the exact same error as Martin. Here are my steps:

Download and prep
------------------------------
1. Download and unzip all 16 files for EBS 12.2.4 single node appliance
2. ls Oracle* | xargs cat > ebs_12.2.4.ova
3. Import appliance into VirtualBox

Getting the server name set
------------------------------
Weblogic password: welcome1
Apps password: apps
EBS SID: EBSDB
Listener Port: 1521

1. From VM startup (apps are already running) login as oracle (assuming the OS passwords have already been changed)
2. source /u01/install/VISION/EBSapps.env
3. r
4. $INST_TOP/admin/scripts/adpreclone.pl appsTier (15 mins)
5. $INST_TOP/admin/scripts/adadminsrvctl.sh stop
6. source /u01/install/VISION/EBSapps.env
7. p
8. $INST_TOP/admin/scripts/adadminsrvctl.sh start forcepatchfs (this is required to start weblogic on the patch environment)
9. $INST_TOP/admin/scripts/adpreclone.pl appsTier (14 mins)
10. /u01/install/VISION/scripts/stopvisionapps.sh
11. /u01/install/VISION/scripts/stopvisiondb.sh
12. connect as root (su -)
13. /u01/install/scripts/configstatic.sh
14. /u01/install/VISION/scripts/visiondbconfig.sh
15. rm -rf /u01/install/VISION/fs1/inst
16. rm -rf /u01/install/VISION/fs2/inst
17. /u01/install/VISION/scripts/visionappsconfig.sh

Posted by Keith Rust on December 10, 2014 at 03:56 PM PST #

Keith,
there's only a problem with fs2, the actual patch file system. As a workaround you can clone fs1, everything works then.
$ adop -status
If adop reports a problem run
$ adop phase=abort
$ adop phase=cleanup cleanup_mode=full
$ adop phase=fs_clone
else just
$ adop phase=fs_clone
If fs_clone reports that ports are already in use change them and re run adop phase=fs_clone

Note that after cloning fs2 is your run environment!
Martin

Posted by Martin Wieland on December 11, 2014 at 08:43 AM PST #

Thanks for the feedback Martin.

And for those jumping into this I found I needed to assign 12 GB of RAM to the VM vs. the recommended 6, unless you enjoy using 4 GB of swap file. ;-) Just turning the VM on consumes 10 GB of RAM and I don't like waiting.

Posted by Keith Rust on December 11, 2014 at 10:59 AM PST #

I get error
error : "failed to execute /u01/install/VISION/fs2/EBSapps/comn/clone/bin/adclone.pl"
Please check logfile.
Application Tier configuration did not complete successfully.

How to i resolve it?

Posted by chuose on February 23, 2015 at 06:17 PM PST #

Hello, Chuose,

I'm sorry to hear that you've encountered an issue with this.

We can provide general conceptual guidance here, but I'm afraid that this blog isn't the best place to get technical support for specific issues like the one that you're working through.

Your best bet would be to log a formal Service Request via My Oracle Support (formerly Metalink) to get one of our specialists engaged.

Regards,
Steven

Posted by Steven Chan on February 24, 2015 at 02:39 PM PST #

Post a Comment:
Comments are closed for this entry.
About

Search

Categories
Archives
« March 2015
SunMonTueWedThuFriSat
1
2
3
5
6
7
8
9
10
11
12
13
14
15
16
18
20
21
22
23
24
25
26
27
28
29
30
31
    
       
Today