X

Technical Articles relating to Oracle Development Tools and Frameworks

  • September 15, 2020

Upgrading the Sample R13 SaaS LightBlue Theme for Visual Builder 20.10

Duncan Mills
Architect

If you have Visual Builder applications that used the sample R13 SaaS LightBlue theme from an earlier version, then you will need to go through a simple upgrade process before trying to run the application under Visual Builder 20.10  Just to explain, there is a jump in the major version of the Oracle JET UI toolkit between these two versions (version 8 of JET to version 9 in this case) and the fallout from that upgrade is that any themes developed against the old version of JET need to be re-generated. The good news is that we've done the hard work for you and you'll just need to go thought the following simple steps to consume this new version of the theme.

Note that you can carry out these steps, even before your Visual Builder instance is migrated to 20.10 all you need to do in that case is to skip the final step until after the upgrade has taken place. Also note that if you create a new application in 20.10 with this SaaS LightBlue theme it will automatically have the correct theme files and you will not have to carry out these steps. Additionally even if you are still on a 19.4 instance and create a new application from the SaaS Lightblue Template then the new version of the theme (4.0.0) will be ready and waiting in the application ready to be switched to when you upgrade

Step 1: Download the updated version of the theme files from GITHub 

Step 2: Open your Application, expand the WebApp in question and right mouse click on the resources/css node.  Choose the Import option and select the ApplicationsCloudUI-4.0.0.zip file you have downloaded, then press the Import button.

Make sure you are importing into the /resources/css sub-folder as shown here.

Step 3:  Select the application in the navigator and open its Application Settings panel. In the Theme select list, select the new 4.0.0 theme as shown here (version number may update over time):

For reference

  • Visual Builder 19.1 (JET 6 runtime): use 1.1.0 of the theme
  • Visual Builder 19.3 (JET 7 runtime): use 2.0.0 of the theme
  • Visual Builder 19.4 (JET 8 runtime): use 3.0.1 of the theme
  • Visual Builder 20.10 (JET 9 runtime): use 4.0.0 of the theme

Be the first to comment

Comments ( 0 )
Please enter your name.Please provide a valid email address.Please enter a comment.CAPTCHA challenge response provided was incorrect. Please try again.