X

News, tips, partners, and perspectives for the Oracle Solaris operating system

Selected FOSS Evaluation Packages (August 2016)

Lukas Rovensky
Senior Manager, Software Development

Today Oracle released evaluation copies
of new and updated versions of selected FOSS components ahead of officially supported Oracle Solaris product releases.

These packages are available at the Oracle Solaris product release repository
for customers running Oracle Solaris 11.3 GA. The source code used to build the components is available at
the Solaris Userland Project on Java.net. The packages are not supported
through any Oracle support channels. Customers can use the software at their own risk.

A detailed how-to guide outlines how to access the selected FOSS evaluation
packages, configure IPS publishers, determine what FOSS components are new or updated, and identify available packages and
download/install them. The guide also contains recommendations for customers with support contracts.

The table of components below contains the available selected FOSS components that are new or updated since
the release of Oracle Solaris 11.3 GA:

New Components

appdirs 1.4.0 cachetools 1.1.5 CACKey 0.7.4 cantarell-fonts 0.0.18
ccid 1.4.20 CGI 4.28 contextlib2 0.5.1 coolkey 1.1.0
DBD-mysql 4.035 dbus 1.10.0 dbus-glib 0.102 exempi 2.2.2
fasteners 0.14.1 funcsigs 0.4 genders 1.22 glib 2.46.0
gnome-backgrounds 3.18.0 gnome-doc-utils 0.20.10 gnu-efi 3.0 gtk-doc 1.24
hicolor-icon-theme 0.15 itstool 2.0.2 jpeg 6.0.2 json-c 0.12
libcroco 0.6.8 libmusicbrainz 5.1.0 liboauth 1.0.3 libpki 0.8.9
libpng 1.4.19 libtiff 4.0.6 libusb 1.0.20 mm-common 0.9.8
monotonic 0.6 mozjs 24.2.0 openca-ocspd 3.1.2 openstack-vswitch 4.0.0
orc 0.4.23 pathlib 1.0.1 pcsc-lite 1.8.14 pika 0.10.0
pika-pool 0.1.3 pygobject 2.28.6 pymemcache 1.3.5 python-editor 1.0
rcssmin 1.0.6 requestsexceptions 1.1.3 sbsigntool 0.6 taglib 1.9.1
unicodecsv 0.14.1 vala 0.30.0 wrapt 1.10.6 yelp-tools 3.18.0
yelp-xsl 3.18.1

Updated Components

amqp 1.4.9 (was 1.4.6) apache2 2.4.23 (was 2.4.16) apr 1.5.2 (was 1.5.1)
asciidoc 8.6.9 (was 8.6.8) augeas 1.5.0 (was 1.3.0) Babel 2.3.4 (was 1.3)
bind 9.10.4-P2 (was 9.6-ESV-R11) cffi 1.5.2 (was 1.4.2) check 0.10.0 (was 0.9.14)
CherryPy 5.1.0 (was 3.8.0) cmake 3.5.0 (was 3.3.2) cmd2 0.6.8 (was 0.6.7)
cov-core 1.15.0 (was 1.7) coverage 4.0.3 (was 4.0.1) cssutils 1.0.1 (was 0.9.6)
cx_Oracle 5.2.1 (was 5.2) d2to1 0.2.12.post1 (was 0.2.10) DBD-SQLite 1.50 (was 1.48)
DBI 1.636 (was 1.623) doxygen 1.8.11 (was 1.8.9) enum34 1.1.6 (was 1.0.4)
facter 2.4.6 (was 2.1.0) fetchmail 6.3.26 (was 6.3.22) filechunkio 1.6 (was 1.5)
flex 2.6.1 (was 2.5.35) FormEncode 1.3.0 (was 1.2.6) gdb 7.11 (was 7.6)
git 2.7.4 (was 2.6.1) gnutls 3.4.9 (was 3.4.6) gparted 0.25.0 (was 0.4.5)
gperf 3.0.4 (was 3.0.3) gpgme 1.6.0 (was 1.5.3) grep 2.25 (was 2.22)
guile 1.8.8 (was 1.8.6) gzip 1.8 (was 1.5) help2man 1.47.3 (was 1.46.1)
httplib2 0.9.2 (was 0.8) indent 2.2.10 (was 2.2.9) irssi 0.8.19 (was 0.8.15)
isc-dhcp 4.3.3-P1 (was 4.1-ESV-R7) iso8601 0.1.11 (was 0.1.10) jsonpointer 1.10 (was 1.0)
kombu 3.0.35 (was 3.0.32) lesscpy 0.11.1 (was 0.9j) lftp 4.7.1 (was 4.6.4)
libarchive 3.2.1 (was 3.1.2) libassuan 2.4.2 (was 2.2.0) libconfuse 3.0 (was 2.6)
libestr 0.1.10 (was 0.1.9) libevent 2.0.22 (was 1.4.14b) libexpat 2.2.0 (was 2.1.0)
libgpg-error 1.23 (was 1.12) libidn 1.33 (was 1.19) libksba 1.3.4 (was 1.3.3)
liblogging 1.0.5 (was 1.0.4) librabbitmq 1.6.1 (was 1.0.1) libsigsegv 2.10 (was 2.6)
libssh2 1.7.0 (was 1.4.2) libxml2 2.9.4 (was 2.9.3) lighttpd 1.4.39 (was 1.4.35)
make 4.2.1 (was 4.1) Mako 1.0.4 (was 1.0.0) Markdown 2.6.6 (was 2.3.1)
MarkupSafe 0.23 (was 0.18) mc 4.8.17 (was 4.8.15) meld 3.16.1 (was 1.8.6)
mercurial 3.8.3 (was 3.7.1) mod_wsgi 4.5.1 (was 4.3.0) modsecurity 2.9.1 (was 2.8.0)
msgpack-python 0.4.7 (was 0.4.6) mutt 1.6.1 (was 1.5.21) mysql 5.5.49 (was 5.5.48)
nano 2.6.1 (was 2.0.9) net-snmp 5.7.2.1 (was 5.4.1) nethack 3.6.0 (was 3.4.3)
nettle 3.2 (was 3.1.1) nghttp2 1.9.2 (was 1.6.0) nmap 7.11 (was 6.25)
nose-cover3 0.1.0 (was 0.0.4) oauthlib 1.0.3 (was 0.7.2) openssl 1.0.2h (was 1.0.2g)
p7zip 15.14.1 (was 9.20.1) pam_pkcs11 0.6.8 (was 0.6.0) passlib 1.6.5 (was 1.6.1)
pep8 1.7.0 (was 1.6.2) pip 8.1.1 (was 6.0.8) pixz 1.0.6 (was 1.0)
ply 3.8 (was 3.7) posix_ipc 1.0.0 (was 0.9.9) postfix 3.1.0 (was 2.11.3)
privoxy 3.0.24 (was 3.0.23) puppet 3.8.6 (was 3.6.2) puppet-solaris_providers 1.2.2 (was 1.0.2)
puppetlabs-apache 1.8.1 (was 1.4.0) puppetlabs-inifile 1.4.3 (was 1.4.1) puppetlabs-mysql 3.6.2 (was 3.6.1)
puppetlabs-ntp 4.1.2 (was 3.3.0) puppetlabs-stdlib 4.11.0 (was 4.7.0) pwgen 2.07 (was 2.06)
py 1.4.31 (was 1.4.26) pycparser 2.14 (was 2.10) pycurl 7.43.0 (was 7.19.5.1)
Pygments 2.1.3 (was 1.6) pyparsing 2.1.4 (was 2.0.1) pyrabbit 1.1.0 (was 1.0.1)
pytest 2.9.1 (was 2.6.4) pytest-cov 2.2.1 (was 1.6) Python 2.7.12, 3.4.5, 3.5.2 (was 2.7.11, 3.4.4, 3.5.1)
python-ldap 2.4.25 (was 2.4.10) pytz 2016.4 (was 2014.10) PyYAML 3.11 (was 3.09)
qunit 1.23.1 (was 1.18.0) rabbitmq-server 3.6.1 (was 3.5.6) rfc3986 0.3.1 (was 0.2.0)
Routes 2.3.1 (was 1.13) rsync 3.1.2 (was 3.1.1) saz-memcached 2.8.1 (was 2.8.1)
scons 2.5.0 (was 2.3.4) scp 0.10.2 (was 0.8.0) screen 4.4.0 (was 4.3.1)
SDL 1.2.15 (was 1.2.14) semantic_version 2.5.0 (was 2.4.2) setuptools-git 1.1 (was 1.0)
sqlite 3.12.2 (was 3.9.2) sqlparse 0.1.19 (was 0.1.14) squid 3.5.18 (was 3.5.5)
subversion 1.9.3 (was 1.7.20) swig 3.0.10 (was 3.0.5) texinfo 6.1 (was 4.13)
text-utilities 2.28 (was 2.25.2) timezone 2016f (was 2015g) tomcat 8.5.3 (was 8.0.32)
tox 2.3.1 (was 1.8.1) trousers 0.3.13 (was 0.3.6) unrar 5.3.11 (was 4.2.4)
waitress 0.9.0 (was 0.8.5) warlock 1.2.0 (was 1.0.1) WebOb 1.5.1 (was 1.2.3)
WebTest 2.0.21 (was 2.0.6) wget 1.18 (was 1.17.1) which 2.21 (was 2.16)
wireshark 2.0.4 (was 1.12.9)

Be the first to comment

Comments ( 0 )
Please enter your name.Please provide a valid email address.Please enter a comment.CAPTCHA challenge response provided was incorrect. Please try again.Captcha