JRuby and Rails - status

JRuby 0.9.8 is out and so is rails-integration 1.0. Rails 1.2.x has been out for a couple of months and there's a new release of ActiveRecord-JDBC 0.2.3. The good news is that JRuby 0.9.8 is lot more Rails compatible than ever before.

For GlassFish users this means:

  • For RoR deployed as a WAR - only the shared mode works. Therefore, instead of running that standalone rake task you should run 'rake war:shared:create'. You need to have the JRUBY_HOME enviroment variable set and a jruby/rails installation.
  • For RoR deployed directly on Grizzly, things seem to have regressed. Hopefully, we'll get the fixes real soon but there are workarounds and if you're interested email me at ashish dot sahni at sun dot com
Stay tuned ...
Comments:

Post a Comment:
Comments are closed for this entry.
About

whacko

Search

Categories
Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today