Wednesday Oct 15, 2008

Firefox3中安装Firefox2的扩展插件

很多Firefox2的扩展或插件在Firefox3中无法安装使用,以下是常见的几中方法,使得旧版本的扩展可以在新版安装。不能安装旧版插件的原因是版本的检查不匹配。所以解决的方法就是跳过版本兼容性的检查。

方法一:修改插件里的支持版本信息
首先将插件下载到本地。FireFox的插件扩展名是xpi,其实是一个zip压缩打包文件,用winrar等可以打开。找到里面的install.rdf文件,可以找到如下内容:
<em:targetApplication>
<Description>
<em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
<em:minVersion>1.5</em:minVersion>
<em:maxVersion>3.0b3pre</em:maxVersion>
</Description>
</em:targetApplication>
minVersion和maxVersion就定义了该插件可以支持的FireFox版本,将3.0b3pre改成3.0,保存后重新安装插件即可。

方法二:设置FireFox,跳过兼容性检查
在FireFox3地址栏输入about:config,出来一个警告页面,不理他,“我保证我会小心”。然后点右键,选择“新建”->“布尔”,创建一个布尔变量
extensions.checkCompatibility,值为false,表示不检查扩展插件的兼容性。
同样的步骤再创建一个布尔变量extensions.checkUpdateSecurity,值为false,不检查安全更新。重启,OK

方法三:使用现成的扩展插件 Nightly Tester Tools
https://addons.mozilla.org/zh-CN/firefox/addon/6543

About

williamxue

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today