X

Proactive insights, news and tips from Oracle WebLogic Server Support. Learn Oracle from Oracle.

  • August 12, 2013

Announcing Web Socket Proxy and Apache 2.4 support for WebLogic Server plug-in customers

We are happy to announce the following enhancements to Oracle WebLogic  Plug-In 12.1.2 release:

- Apache 2.4 Support - WLS Plug-In 12.1.2+ is now supported with
vanilla Apache 2.2.x and 2.4.x Web Servers. Customers interested in using WLS
Plug-In with vanilla Apache 2.4.x Web Server can download our latest  WLS
Plug-In 12.1.2  patch from OTN - http://www.oracle.com/technetwork/middleware/ias/downloads/wls-plugins-096117.html

- WebSocket Proxy Support  -  WLS Plug-In 12.1.2+ for
Apache HTTP Server 2.2.x , 2.4.x Web Servers can now front-end WebSockets
applications deployed within WLS 12.1.2. This WebSocket Proxy capability is
currently unavailable for OHS and other 3rd party web servers like IIS and
iPlanet Web Servers. 

- This enhancement is tracked via bug - 17085296  and is available only for
WLS Plug-In 12c release. Also, these enhancements are NOT available for OHS
12.1.2 release. OHS 12.1.3 will deliver the WebSocket Proxy capability.
 Our FMW 12.1.2 certification matrix is being updated to reflect that WLS
Plug-In 12.1.2 supports Apache 2.4 Web Server.  

- This enhancement is downloadable either as a patch, for a
corresponding platform, from Oracle Support - or from OTN - http://www.oracle.com/technetwork/middleware/ias/downloads/wls-plugins-096117.html . 

- This enhancement, like any other WLS Plug-In patch, is
delivered as a complete zip file and the installation experience is same as WLS
Plug-In 11g/12c release. The 'README' provides more information regarding
these new capabilities. The next doc refresh for WLS Plug-In 12c product
documentation will include this information as well. 

- Last but not least, any future patches for WLS Plug-In 12.1.2 will
include these enhancements as well.  This enhancement addresses several of
our customers long standing wish regarding Apache 2.4 Web Server support. 


Join the discussion

Comments ( 5 )
  • Andreas Dijkman Tuesday, August 13, 2013

    Is this plugin also recommended or certified for Weblogic 12.1.1?


  • Frances Zhao Wednesday, August 14, 2013

    Hi Andreas,

    Yes, this is certified with WebLogic 12.1.1.

    Best,

    -Frances


  • guest Friday, April 3, 2015

    Does weblogic 10.3.6 works with apache 2.4.x?


  • mbogucki Thursday, September 3, 2015

    Weblogic 10.3.6 works with apache 2.4.x - see ID 2013803.1


  • guest Thursday, September 3, 2015

    WebLogic Server Proxy Plug-In 12c is backward compatible with WebLogic Server Proxy Plugins 11gR1 but supports only 64-bit Web Servers.


Please enter your name.Please provide a valid email address.Please enter a comment.CAPTCHA challenge response provided was incorrect. Please try again.