Tamarack, Gnome 2.17 and external devices

This is a combination that I've been hanging on. vold never quite handled my cds, dvds and usb media quite right.

I'm happy to say that for the most part it all just works like it should.

Well, I have a multi-partitioned usb device which exhibits an interesting problem.

First, let's have a look at how the device (it's a 60gb usb 2 disk) is partitioned.

             Total disk size is 57231 cylinders
             Cylinder size is 2048 (512 byte) blocks

                                               Cylinders
      Partition   Status    Type          Start   End   Length    %
      =========   ======    ============  =====   ===   ======   ===
          1                 Ext Win95         1  28615    28615     50
          2                 Solaris2      28616  57230    28615     50 

Partition 1 has a fat-32 filesystem.
Partition 2 has an SMI label and slice 0 is a zfs pool with the imaginitve name 'usb'.

# fstyp /dev/dsk/c4t0d0p1
pcfs
# fstyp /dev/dsk/c4t0d0s0
zfs

If I insert this disk into my notebook running b53, I get the notice about not being able to mount the zfs pool (which I expect), but it does not notice the fat-32 partition, let alone mount it:

# rmmount -l
/dev/dsk/c4t0d0s0    rmdisk,rmdisk0,usb

I had a chat with one one of the developers about this. He found that if we place the zfs pool directly into the second partition, then everything works as you would expect. The different controller numbers and zfs pool name are purely due to using another disk and machine in anotehr continent.

# fstyp /dev/dsk/c2t0d0p1
pcfs
# fstyp /dev/dsk/c2t0d0p2
zfs
# rmmount -l
/dev/dsk/c2t0d0p0:1  rmdisk,rmdisk0,NONAME,/media/NONAME
/dev/dsk/c2t0d0s2    rmdisk,rmdisk0,lacie_p2

It turns out that if hal discovers an SMI label on any partition, it does not probe any of the other logical disks, leading to the logging of

6502219 If SMI label exists, hal does not probe logical disks

In the meantime as I really don't want to muck around with the existing zpool, I'll continue to mount my pcfs manually, but it will be nice when this one is fixed.

It's probably also worth mentioning that "zpool import usb" just works.

Technorati Tags: ,

Comments:

Post a Comment:
Comments are closed for this entry.
About

* - Solaris and Network Domain, Technical Support Centre


Alan is a kernel and performance engineer based in Australia who tends to have the nasty calls gravitate towards him

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today
Links
Blogroll

No bookmarks in folder

Sun Folk

No bookmarks in folder

Non-Sun Folk
Non-Sun Folks

No bookmarks in folder