A known bug with the Sun Studio 11 compilers and tools installer

Due to a dependency that wasn't noticed in time, there is a small problem with the Sun Studio 11 installer on Solaris platforms. The installer is supposed to work with any Java 2 JVM. Unfortunately it will not in fact work with any JVM that is pre 1.4. One of two symptoms may occur. Either an exception during deserialisation, or an exception stating that the class com.sun.install.products.Product was not found.

If you experience this issue, and you have a 1.4 or later JVM available on your machine, simply set your PATH so that that version of java is first. If you do not have a 1.4 or later JVM, then you will need to install one. You should install the full JDK, since the installer will then not offer to reinstall it.

I believe this problem was introduced when I added support for Zones to the installer. I switched to a later release of the Installer SDK, which introduced the dependency on a 1.4-only class.

Comments:

Post a Comment:
  • HTML Syntax: NOT allowed
About

terryh

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today