X

The Latest Technology Stack News Directly from EBS Development

Safari 12 Implications for E-Business Suite Users

Steven Chan
Senior Director

Customers have been asking about the compatibility of new versions of the following Apple products with Oracle E-Business Suite Releases 12.1 and 12.2:

  •          Safari 12 (works with macOS 10.13.6 and 10.12.6)
  •          macOS Mojave (macOS 10.14)

Neither of these two products have been certified with either EBS 12.1 or EBS 12.2 as of September 18, 2018.  

Safari 12 is unable to launch Java in the way that prior Safari versions could. This will prevent E-Business Suite 12.1 and 12.2 customers from running Forms-based products. Therefore, customers should *NOT* upgrade to Safari 12 on macOS desktop platforms.

macOS Mojave (macOS 10.14) includes Safari 12. Customers should *NOT* upgrade to macOS Mojave.

We are aware of the potential impact to E-Business Suite users and are actively pursuing solutions.    

What has changed?

Safari 12 introduces an important change: it removes support for “legacy NPAPI plug-ins”. This affects all EBS releases. macOS Mojave includes Safari 12.

Some products within Oracle EBS 12.1 and 12.2 run via HTML in browsers. These products are sometimes called “self-service web applications”. They are expected to run without issue in Safari 12, but our certification testing is still underway.

Some products within Oracle EBS 12.1 and EBS 12.2 use Oracle Forms. Oracle Forms requires Java for desktop clients. On the macOS desktop platform, the only certified option today for launching Java is via the JRE plugin via the NPAPI approach.

This means that Safari 12 and macOS Mojave (macOS 10.4) will be unable to use the current JRE plugin-based launching technology for Java and Forms for EBS desktop users.

Recommendations for EBS customers

As of today, the latest certified versions of these products are:

  • Safari 11 (works with macOS 10.13)
  • macOS High Sierra (macOS 10.13)

EBS customers should use only certified configurations. EBS customers who use Forms-based products should avoid upgrading to Safari 12 or macOS Mojave today.

What’s next for EBS clients on macOS?

We have certified Java Web Start (JWS) for Windows clients accessing EBS 12.1 and 12.2 environments. Java Web Start is an alternative to the JRE plugin approach. Java Web Start works with browsers that lack NPAPI support. For more details about Java Web Start and EBS on Windows, see:

We are working on certifying Java Web Start technology with macOS. Our goal is to provide a solution that allows E-Business Suite users on macOS to continue without any reduction in functionality. Given changes to Safari and Apple’s security model, we are examining options for browsers such as Firefox.

Once again, we are acutely aware of the potential impact to E-Business Suite users and have been working on solutions for macOS for some time.

Oracle’s Revenue Recognition Rules prohibit us from discussing certification and release dates, but you’re welcome to monitor or subscribe to this blog. I’ll post updates here as soon as soon as they’re available.   

Related Articles

Join the discussion

Comments ( 7 )
  • Quentin North Tuesday, September 25, 2018
    Also stops working Firefox v60. This is a major issue for universities using Forms and EBS as we tend to run a mixed Mac/PC desktop estate with less central control over deployed applications.
  • Ismail Thursday, September 27, 2018
    Now i cannot use my mac for EBS. quickly i have to look for other laptop with window OS. It is total loss for me.
  • Chandrakant Friday, September 28, 2018
    Noted your comments, however, I and my other colleagues having Mac, have already upgraded to Safari 12 and evne to Mojave. What should we do now ?? Are these reversible ?Can one go back to previous version of either Safari or Java so that in the interim we can use R12 - EBS.
  • Steven Chan Monday, October 1, 2018
    Quentin, Ismail,

    Yes, we understand the impact to macOS users. As stated in the article above, we are working on this.

    Chandrakant,

    I'd recommend contacting Apple Support for assistance with questions about backing out Safari or Mojave upgrades. Apple is the best organization to handle generic questions about their software.

    Regards,
    Steven
  • Ram Wednesday, October 3, 2018
    I use firefox (and disabled updates and stuck at 50.0.2. Also found another browser Seamonkey. Works perfectly for with EBS.

    Thanks
    Ram
  • François Gendron Wednesday, October 3, 2018
    Waterfox for mac, a firefox clone with NPAPI will work just fine in the meantime.
  • David Monday, October 8, 2018
    For new devices shipping Mojave, there is no option to downgrade Safari.

    Java Deployment Technologies are quickly changing/disappearing and EBS needs to move more smartly and quickly to the present instead of clinging to old tech for Oracle Forms. It's only going to hurt your bottom line.

    Even if IE11 is dragged onward via life support for the life of Windows 10, no one is using it.
Please enter your name.Please provide a valid email address.Please enter a comment.CAPTCHA challenge response provided was incorrect. Please try again.Captcha
Oracle

Integrated Cloud Applications & Platform Services