Friday Oct 19, 2012

Planning Bulletin for JRE 7: What EBS Customers Can Do Today

 [Update Dec. 11, 2012: JRE 7 is now certified with the E-Business Suite; see this announcement for complete details.]

An initiative to certify Oracle E-Business Suite with JRE 7 desktop clients is underway.  We have tested EBS 11.5.10.2, 12.0, and 12.1 with JRE 7. We have fixes for nearly all of the compatibility issues now, and are working hard to produce the remaining fixes quickly.

A. When will JRE 7 be certified with Oracle E-Business Suite?

We will announce the certification of the E-Business Suite with JRE 7 once all fixes are available, verified, and documented.  Certification announcements will be distributed through My Oracle Support, My Oracle Support Community Forums, Oracle Technology Network Forums, newsletters, and user group news outlets.

Oracle's Revenue Recognition rules prohibit us from discussing certification and release dates.  In addition to the standard communication channels listed above, customers are encouraged to monitor or subscribe to this blog.   

B. What can customers do to prepare for the JRE 7 certification?

Customers should ensure that they are on the latest available JRE 6 update.

Of the compatibility issues identified so far with JRE 7, the most critical is an issue that prevents E-Business Suite Forms-based products from launching on Windows desktops that are running JRE 7. 

Customers can prevent this issue today by ensuring that they have applied the latest certified patches documented for JRE 6 configurations to their EBS application tier servers:

  1. Apply Forms patch 14615390 to EBS 11i environments (Note 125767.1)
  2. Apply Forms patch 14614795 to EBS 12.0 and 12.1 environments (Note 437878.1)

These patches are compatible with JRE 6 and 7, production ready, and fully-tested with the E-Business Suite.  These patches may be applied immediately to all E-Business Suite environments. All other Forms prerequisites documented in the Notes above should also be applied now.

C. What else will be required by the final certified configuration?

Oracle expects that all other compatibility issues will be resolved by installing a specific JRE 7 release, at minimum.  That specific release has not been finalized yet, and this is subject to change.

D.  Where will the official patch requirements be documented?

All patches required for ensuring full compatibility of the E-Business Suite with JRE 7 will be documented in updates to these published Notes:

For EBS 11i:

For EBS 12
Disclaimer

The preceding is intended to outline our general product direction.  It is intended for information purposes only, and may not be incorporated into any contract.   It is not a commitment to deliver any material, code, or functionality, and should not be relied upon in making purchasing decision.  The development, release, and timing of any features or functionality described for Oracle’s products remains at the sole discretion of Oracle.

About

Search

Categories
Archives
« October 2012 »
SunMonTueWedThuFriSat
 
1
3
4
6
8
10
11
12
13
14
15
20
21
22
23
24
25
27
28
   
       
Today