X

News, tips, partners, and perspectives for the Oracle Solaris operating system

  • April 16, 2019

Announcing Oracle Solaris 11.4 SRU8

Albert White
Manager, Software Maintenance Engineering
Today we are releasing the SRU 8 for Oracle Solaris 11.4. It is available via 'pkg update' from the support repository or by downloading the SRU from My Oracle Support Doc ID 2433412.1.

This SRU introduces the following enhancements:

  • Integration of 28060039 introduced an issue where any firmware update/query commands will log eereports and repeated execution of such commands led to faulty/degraded NIC. The issue has been addressed in this SRU.
  • UCB (libucb, librpcsoc, libdbm, libtermcap, and libcurses) libraries have been reinstated for Oracle Solaris 11.4
  • Re-introduction of the service fc-fabric.
  • ibus has been updated to 1.5.19

The following components have also been updated to address security issues:

  • NTP has been updated to 4.2.8p12
  • Firefox has been updated to 60.6.0esr
  • BIND has been updated to 9.11.6
  • OpenSSL has been updated to 1.0.2r
  • MySQL has been updated to 5.6.43 & 5.7.25
  • libxml2 has been updated to 2.9.9
  • libxslt has been updated to 1.1.33
  • Wireshark has been updated to 2.6.7
  • ncurses has been updated to 6.1.0.20190105
  • Apache Web Server has been updated to 2.4.38
  • perl 5.22
  • pkg.depot

Full details of this SRU can be found in My Oracle Support Doc 2529131.1. For the list of Service Alerts affecting each Oracle Solaris 11.4 SRU, see Important Oracle Solaris 11.4 SRU Issues (Doc ID 2445150.1).

Join the discussion

Comments ( 2 )
  • Marco Tuesday, May 14, 2019
    Hi,
    I currently administer a solaris operating system 11.3 SRU 35 and I have the following questions?
    1. Will SRU continue for Solaris 11.3?
    2. When does Solaris 11.3 support end?
    3. Can I install more updates to Solaris 11.3 to keep it free of vulnerabilities and risk?
    4. Can I migrate to Solaris 11.4 and continue using Java 1.7 32bits?

    Thank you very much for the answers.
  • Alan Coopersmith Wednesday, May 15, 2019
    Solaris 11.3 SRU's ended when Solaris 11.4 shipped in August 2018. A limited selection of fixes is being provided in Limited Support Updates (LSUs) on a quarterly basis for at least a year past that point for those who need more time to transition, but it does not include all the fixes that are going into 11.4. See https://support.oracle.com/knowledge/Sun%20Microsystems/2382427_1.html for further details.

    As for Java on Solaris 11.4, the version of Java provided with Solaris is the one needed for the Java software included with Solaris, so is only the 64-bit Java 1.8 in 11.4. You can continue to install and use Java 1.7 in either 32 or 64 bit yourself, but you'll need to pay for the Java SE extended support to get fixes past this July: https://www.oracle.com/technetwork/java/java-se-support-roadmap.html
Please enter your name.Please provide a valid email address.Please enter a comment.CAPTCHA challenge response provided was incorrect. Please try again.Captcha