X

PaaS Partner Community

  • February 27, 2015

BPM & SOA Application missing in JDeveloper 12c gallery by Martien van den Akker

Juergen Kress
PaaS & Middleware Partner Adoption
clip_image001

A few weeks ago I did a BPM12c Quickstart Installation under Oracle Linux 6. Everything went smoothly, as described in the install guide as well as on many blogs already.
But I found that most of those blogs did an installation under Windows, where I did it under Oracle Linux in Virtualbox.
You would think (as I did) that it shouldn't matter. However, it turns out that in JDeveloper I was missing the 'BPM Application' amongst others in the JDeveloper New Gallery. Very inconvenient. I couldn't find any hints on the big internet. My friend Google wasn't very helpful in this.
But I wouldn't write this blog if I did not solve it. It turns out that with an update I got it solved.
It turns out that I lacked the 'Spring & Oracle Weblogic SCA' extension. Using the Help->Update functionality I downloaded and installed that and after restarting JDeveloper my 'New Gallery' was properly filled.
For those not so familiar with the JDeveloper update mechanism, here a step by step guide:

Choose Help->Update: Read the complete article here.

SOA & BPM Partner Community

For regular information on Oracle SOA Suite become a member in the SOA & BPM Partner Community for registration please visit www.oracle.com/goto/emea/soa (OPN account required) If you need support with your account please contact the Oracle Partner Business Center.

Blog Twitter LinkedIn image[7][2][2][2] Facebook clip_image002[8][4][2][2][2] Wiki

Join the discussion

Comments ( 3 )
  • guest Wednesday, October 14, 2015

    Hi Jürgen,

    I have faced the same problem and done as you suggested. It works. Thanks for sharing the solution.

    Thanks.

  • guest Monday, November 23, 2015

    Hi,

    This does not work for 12.2.1 and I could not figure out a way for 12.2.1. All, I have now is the quick install option for BPM. Any pointer would be highly helpful.

    Thanks
    Angshu

  • guest Tuesday, June 14, 2016

    Hi,

    I faced similar issue in windows. Followed your suggestion, it got resolved.

    Thanks!

Please enter your name.Please provide a valid email address.Please enter a comment.CAPTCHA challenge response provided was incorrect. Please try again.