Friday Feb 05, 2010

More Font Hiccups with Build 132

A couple of weeks ago, I upgraded to build 131 and had a font hiccup. And I thought I'd fixed things up by ensuring that the 'extra' repo was active.

Well, today when I upgraded to build 132 (yes, with 'extra' active) I hit the same problem. This still looks like a match to bug 13912 - image-update of b131 stops when ttf-fonts-core extra package is installed. But when I look at the packages in 'extra', I don't see the ttf-fonts-core package anymore.

I decided to remove my (now, quite old) version of the package:

# pkg uninstall system/font/truetype/ttf-fonts-core

From there, the upgrade went fine. Hopefully I'm out of the woods when build 133 comes along.

:wq

Friday Jan 22, 2010

Font Hiccup on Build 131 Upgrade

I upgraded to build 131 this morning and hit a hiccup on X11 TrueType fonts. About 75% into the install, Update Manager stopped complaining about files in usr/X11/lib/X11/fonts/TrueType. I moved the TrueType directory out of the way and the install proceeded.

After the upgrade worked, I found 6905518 which shines some light on the problem. The 'TrueType' directory becomes a symlink to /usr/share/fonts/TrueType. So I plopped my fonts in their new location post-upgrade and all is well.

:wq


Update:
Happened upon image-update of b131 stops when ttf-fonts-core extra package is installed and sure enough my 'extra' repo wasn't active. Off to update my keys and certificates for 'extra'.
About

user9148476

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today