Monday Jan 04, 2010

OpenSolaris b130 upgrade...bug at login

b130 Sparse Desktop Just returned to work for the new year, upgraded my Toshiba laptop to b130, and got smacked with bug 9755 after reboot. Basically "ICEauthority" type errors when the graphical login starts up and a "sparse" desktop once you're logged in (no launch icons, missing scroll bars, etc).

The bug talks of the 'gdm' user needing its $HOME set to /var/lib/gdm, but doesn't specifically list a workaround.

I tried the following change to /etc/passwd:

# diff /etc/passwd.orig /etc/passwd 12c12 < gdm:x:50:50:GDM Reserved UID:/: --- > gdm:x:50:50:GDM Reserved UID:/var/lib/gdm:

This got rid of the "ICEauthority" and subsequent errors, but the "sparse" desktop remains. Will continue playing as time permits today...


Jees...I should read release notes. They detail this workaround:

% pfexec usermod -d /var/lib/gdm gdm

The moral equivalent of the above, but easier (and safer too). Alas, this did not correct my "sparse" display. Nor did the OpenGL switcher fix.


Thanks to Eldee for the xorg.conf suggestion. I commented out this line:

# Option "MigrationHeuristic" "greedy"

and my desktop is complete again. Performance is off some, but working. I also tried the experiment of removing my custom xorg.conf as follows:
  1. svcadm disable gdm
  2. Login as a user, su to root
  3. mv /etc/X11/xorg.conf.\* ~
  4. reboot
  5. Login as a user, su to root
  6. svcadm enable gdm
This also worked fine. Going to run without the customizations for a while....see how that goes.

:wq

About

user9148476

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today