Groovy / Grails added into standard distribution

The Groovy/Grails support has been added to the standard distribution of NetBeans. You can test it in the nightly build. Yes, that means that NetBeans 6.5 will ship including Groovy support! :)

Comments:

HI thats cool and as hot news Milos and myself working on add mevenide (maven support) to standard distribution of NetBeans .Hope we manage to it on 6.5 :).

see whats latest on http://wiki.netbeans.org/MavenBestPractices

Posted by Anuradha Gunasekara on červen 18, 2008 at 12:10 dop. CEST #

Thats pretty cool.

Posted by lzap on červen 18, 2008 at 01:41 dop. CEST #

I'm using Netbeans 6.1 and there was a problem compiling Groovy source code with Netbeans Maven plugin, because maven is searching for Groovy sources files in directory [src/main/groovy/\*, src/test/groovy/\*] and Netbeans works with [src/main/java/\*, src/test/java/\*] directories.

Posted by Richard Mihalovic on červen 18, 2008 at 02:01 dop. CEST #

That's great. I love Grails! I hope you guys are surpassing what those Eclipse guys have done with their plugin. :)

Posted by Matthias Schmidt on červen 18, 2008 at 04:15 dop. CEST #

I really liked and loved the new features of NetBeans 6.1, but the 6.5 version will be full of fun. Great work!

Posted by Hubert Klein Ikkink on červen 18, 2008 at 04:19 dop. CEST #

ok

Posted by 手机魔卡 on červen 18, 2008 at 01:48 odp. CEST #

That's great news. I will ask our developers to start using new features of NetBeans 6.1.
Good work!

Posted by Deepak Kumar on červen 24, 2008 at 08:24 dop. CEST #

Hi Roumen

I downloaded the \*latest\* build from the given link and when i installed and ran the IDE, i got the following error:

Warning - could not install some modules:
Groovy Editor - The module Diff was requested in version >= 1.19 but only 1.17.0.42.1 was found.
Common Scripting Language Support - The module Diff was requested in version >= 1.20 but only 1.17.0.42.1 was found.
53 further modules could not be installed due to the above problems.

What's the exact problem here?

Posted by kodeninja on červen 25, 2008 at 06:24 dop. CEST #

Great news!

If I don't need the absolute bleeding edge version but I don't want to wait until 6.5 is out, are there any intermediate builds coming that I could look forward to or is nightly the best bet?

Posted by Paul King on červen 25, 2008 at 07:52 dop. CEST #

Take 'All' or 'Web & Java EE' from http://bits.netbeans.org/download/trunk/nightly/latest/

Posted by Martin Adamek on červen 25, 2008 at 09:25 dop. CEST #

I tried to create a new Grails project (File/New Project/Groovy/Grails application), but got this exception:

java.lang.IllegalStateException: Method must be invoked from EDT.

I am unable to create any new Groovy/Grails application.

Posted by Roshan Shrestha on červen 26, 2008 at 11:29 dop. CEST #

Congrats, even though I am an Eclipse guy and a committer to Groovy Eclipse, I am also a Groovy/Grails guy. The more we can get for tooling and support will push the whole ecosystem further. I might have to check it out, if only to figure out what I could poach. ;)

Now if I only had unlimited amounts of unpaid time to devote, maybe we could get Groovy Eclipse in the default installation for Eclipse. That would be great, since it would cover the great majority of Java developers. I wonder if IntelliJ is shipping Groovy support by default?

Posted by James E. Ervin on červen 29, 2008 at 03:35 odp. CEST #

Yes, I believe the newest version of IntelliJ IDEA has built in Groovy support.

Posted by Roman Strobl on červen 29, 2008 at 03:42 odp. CEST #

Great news! Can't wait to try it out. Excellent job, you guys are doing.

Posted by Raju Bitter on červenec 20, 2008 at 04:51 odp. CEST #

Post a Comment:
Comments are closed for this entry.
About

Roman Strobl

Search

Archives
« duben 2014
PoÚtStČtSoNe
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
    
       
Today