X

Pat Shuff's Blog

upgrade reasons


The big discussion that I get drawn into on a regular basis is "why upgrade". Why should someone go from something that is working fine to months of effort and potential cost? What is the value in change? Why do something different? In this blog entry, I will try to address these two questions.

Let's start with a baseline. Steven Chang does a good job in his blog describing premium support, extended support, and sustaining support. To summarize here, premium support is what you want. extended support will cost you 20% more in support cost, and sustaining support is what you want to avoid. Not to say that sustaining support is that bad, it just costs more and locks you into a really old system with little or no changes. If congress changes something like the time zone again, sustaining support might or might not provide a patch to fix the issue. Given that all countries are now looking at changing time zones on a regular basis to save tax payers money, sustaining support might cause problems if you are operating in other countries. No one really expects a patch set for 11.5.8 given that it was put into sustaining support over 10 years ago. No one really expects Microsoft to patch Windows 3.1 or the original version of Word.

The current releases that are supported are EBS 11.5.10 until Nov 2011 in premium support and EBS 12.1 until May 2014. Given that EBS 11.5.9 was released 7 years ago in Jun 2003 and entered premier support in Jun 2008, extended support will not be available for this release. If you choose to stay on 11.5.10 after Nov 2010, you have until Nov 2013 when extended support ends. Note that all are supported in sustaining support for an additional charge but it quickly looses value the longer you use it.

The databases that are supported for EBS are 10.2.0.5 through Nov 2011, 11.1.0.7 until Aug 2012, and 11.2 until Jan 2015. Extended support for 10.2 ends in Jul 2013, 11.1 in Aug 2015, and 11.2 in Jan 2018. Note that the database support timelines do not sync up with the EBS release dates.

Basically what it comes down to is that the 11.5.10 version of EBS is about 6 years old and 10.2 of the database is 5 years old. Technologies have significantly changed in 5 years. Laws have changed. Processes and procedures have changed. The way that businesses do business have changed. To compensate for these changed you typically have customized you instance and made changes to your policies and procedures. Getting information out of this system is also aged and out of date. Reading data from a database is not necessarily the right thing to do now. Many vendors have built reporting tools for EBS 11.5.9 and 11.5.10 that are also aging and do not integrate well with other software. New trends like integration of manufacturing, inventory, and cost of labor to get cost of goods sold are not possible.

There are a variety of reasons to upgrade to EBS 12.1. We will not go into them all here because they vary based on what package you are using. The biggest value that I hear is multinational general ledger support. Instead of manually converting currencies into a common currency and converting the general ledger of one country into a line item of a central general ledger, each business unit or operating company can become a part of the general ledger with drill down capabilities that bubble up into a master ledger. I realize that there are many other advantages. You can find them in the reasons to upgrade link.

The major components that are under EBS are the technology components. These components are:


  • Application Server
  • Database Server
  • Java Virtual Machine
  • Operating System

The processors that were available in 2005 were single core 3Ghz Pentium processors. These chips had 300M transistors on 65nm. The dual core system was introduced but not widely used at the time because most operating systems could not take advantage of multiple core systems. Quad core was introduced in 2007 and had a transistor count of 800M on 45nm line widths. The newest Intel processors operate at 3.6Ghz and have double the amount of cache with more threads and parallel processing.

According to the upgrade guide, the first things that you need to do are stabilize your hardware, operating system, and database. Since the Oracle database runs on a variety of hardware and operating systems, you should select what you staff is comfortable with. It is important to realize that although Oracle does not "favor" one release over another, the release schedules are different for each operating system.

The minimum database that is recommended for EBS 12.1 is 10.2.0.5. If you are not on this version, you should upgrade to this first. This will give you until Jul 2013 until you have to upgrade the database again. You can also upgrade to 11.1.0.7 or 11.2. This will give you five or eight years before you have to upgrade again.

The difficult questions that need to be asked are with the application server. Do you upgrade to the latest version or migrate to WebLogic Server. Given that iAS 10gR2 was initially released in 2005 and goes to extended support in 2011, you should upgrade to 10gR3 or 11gR1. The 11gR1 release was in 2009 and goes to extended support in 2014. The safe bet would be to migrate to WebLogic but this will require retraining of your staff and changing the way that you deploy applications and test instances.

Next entry, looking at upgrading the database and different ways of getting to a newer version.

Be the first to comment

Comments ( 0 )
Please enter your name.Please provide a valid email address.Please enter a comment.CAPTCHA challenge response provided was incorrect. Please try again.Captcha