PeopleTools 8.54 – New Functionality, New Browser Releases

PeopleTools 8.54 has numerous enhancements to offer, but it does have some browser requirements that go along with it as well.  As customers look at the much improved user interface along with other enhancements being delivered in PeopleTools 8.54, they will look to take advantage of the release and plan their upgrade.  As they plan, diligent customers will review certifications and notice that PeopleTools 8.54 certifies only newer browser releases.  For Internet Explorer, IE 9 is the absolute minimum for the Classic UI, and IE 11 (or higher) is required to take advantage of the new Fluid UI.  As they continue to prepare for the upgrade, some may discover that they have older applications that have hard requirements for a less than current IE release.  Can you say IE 8?  I have come across a couple scenarios already where customers have that one critical application that hasn’t been updated in 5+ years and requires the use of IE 8; it can’t work with IE9 or above.  Another situation I’ve seen is where a customer isn’t scheduled to roll out IE 9 (or above) to their user base prior to their scheduled go live date.

As they evaluate options, some customers facing this situation are able to implement a dual browser environment using Chrome or Firefox for PeopleSoft, and an older IE browser required for antiquated applications.  Other customers have begun to ask what PeopleTools functionality might simply not work if they decide to move forward with an uncertified browser environment.  Since we test our software with certified browser combinations, we sometimes aren’t sure which features might be partially supported by older browsers, and which simply won’t work.

The problem is that older versions of Internet Explorer simply did not contain the functionality that current browsers have.  While those versions render HTML and CSS content, they often do so in very specific, non-standard fashion.  A state of the art application like PeopleSoft relies on rich functionality implemented in the latest versions of the HTML and CSS standards.  PeopleSoft utilizes AJAX and the latest accessibility suggestions as outlined in the Web Accessible Initiative – Accessible Rich Internet Applications Suite (WAI-ARIA).  IE 8 and previous browsers were not designed to support this functionality adequately, and cannot deliver the performance that modern browsers do.

We expect that the following areas would be problematic if using IE 8 or (gulp) something older with the Classic UI.  Of course, Fluid UI functionality will not work.

  • Layout issues
  • Nonfunctional breadcrumbs
  • Accessibility problems
  • Performance issues
  • Problematic charts and graphs
  • Mobile Application Platform (MAP)

Note that there are almost certainly other issues that would arise from the use of outdated and uncertified browsers.

As you make plans to roll out the best release of PeopleTools yet, we STRONGLY recommend that you use only certified environment components.  We test and certify environments for a reason - so that we can find as many issues as possible, before you do.  Should you find a bug we missed, our Support organization stands ready to assist you in obtaining a resolution in your certified environment.  We want your roll out to be as smooth as possible - take advantage of our testing and give your users the best experience available.

Comments:

Well said Mark! Another option if your organization doesn't allow a second browser other than IE, although not ideal, would be to run Peoplesoft as a published virtual app on IE11....or move that older app that still needs IE8 to a published virtual app model and upgrade everyone else to IE11. (Citrix would be one example)

Posted by guest on August 14, 2014 at 03:53 PM PDT #

Post a Comment:
Comments are closed for this entry.
About

This blog provides information to the PeopleSoft community, about PeopleSoft Technology, otherwise PeopleTools.

For information about PeopleSoft see the PeopleSoft Strategy Blog.

For information about PeopleTools 8.53 and 8.54 see the PeopleTools Patch Updates.

Search

Archives
« April 2015
SunMonTueWedThuFriSat
   
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
  
       
Today