星期四 八月 29, 2013

Using SQL Developer to connect TimesTen server

Just A Note for my today's operation.


SQL Developer Version:  3.2.09

TimesTen Version:  11.2.2.5.1

Server: Linux_X64 6.4

Client: Windows 7


Prepare on Server:

Add DSN imdb1 into sys.odbc.ini:

[ODBC Data Sources]
TT_1122=TimesTen 11.2.2 Driver
imdb1=TimesTen 11.2.2 Driver

......

[imdb1]
Driver=/u01/app/TimesTen/tt1122/lib/libtten.so
DataStore=/u01/app/TimesTen/imdb1/imdb1
DatabaseCharacterSet=WE8MSWIN1252
PermSize=2000
TempSize=1000
PLSQL=1

Startup the instance and the DSN.

Prepare on Client:

Install Client 11.2.2.5.1 on Windows 7.

Configura ODBC:


Copy the C:\TimesTen\tt1122_64\client32\lib\ttjdbc6.jar to D:\Program Files (x86)\SQL Developer\jdbc\lib.

Add JDBC to SQL Developer:

Connect to the tt:

I add tcp_port into the input box because of the errors:

状态: 失败 -无法连接到数据库。遇到的错误为: Unable to connect to data source (DSN: myhost.com; Network Address: myhost.com; Port Number: 53393). Cannot connect to TimesTen Server.  Verify that the TimesTen Server is running or verify that your TCP PORT is set correctly.

Test the connectivity is OK in ODBC, but SQL Developer keep the wrong port during the connection, so the tcp_port is necessary.

About the error:

If running JVM on 32 bit, shuld install 32 bit TT Client, and change the $CLASSPATH to C:\TimesTen\tt1122_64\client32\lib\ttjdbc6.jar; instead of C:\TimesTen\TT1122~1\lib\ttjdbc6.jar;

Also should add C:\TimesTen\tt1122_64\client32\bin to $PATH




星期二 八月 06, 2013

Forced to Install Oracle 10g r2 on Oracle Linux 6.4

Oracle Linux 6.x is not support Oracle 10g.

However, the key to forced to installed Oracle 10g r2 on Oracle Linux 6.x 64Bit is the following rpm:

libXt.i686

libXtst.i686

These two rpms is used to avoid libawt.so: libxt.so.6 errors, not recommend.

About

Oracle Blogs Admin-Oracle

Search

Categories
Archives
« 四月 2014
星期日星期一星期二星期三星期四星期五星期六
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
今天