Wednesday Mar 25, 2009

Network manager for OpenSolaris

Hi All,

  So my friend Tom actually pulled it off. Thanks Tom

Hopefully the test tar.bz2 will be on http://kb7sqi.com/opensolaris/


Tuesday Mar 24, 2009

SDcard mounting issues on the MSI and AA1-10 netbooks

Hi All,

  So I was having issues with SDcards mounting on the MSI and AA1-10, so I opened a bug on it.

 Guoqing Zhu from the Beijing development group was just logged into the MSI system upstairs, he found the problem.

  I had formatted the sdcards on Windows XP Home.

  Once I used his suggested mkfs command :

  mkfs -F pcfs -o fat=32,spc=64 /dev/rdsk/c4t0d0p0:1

  spc=64 being the correct parameter, all my sdcards started mounting and unmounting correctly.

CR 6760291

Autoscan Network 1.41 on OpenSolaris

Hi All,

 This is not my work, it's a really cool guy in my group, Tom Karbowski in Chicago that's making it work.

 And it's not easy as most of the code is in French, this is not to say anything bad about French, it is not our native language.

 This was the first run of the port on OpenSolaris B109


Monday Mar 23, 2009

MSI Wind Netbook and Compiz 0.8.0 on OpenSolaris B110 - Success

Hi All,

 Well I spent the whole day rebuilding the entire compiz packages, I've got 0.8.0 on the MSI Wind Netbook.

 I still had to do a full power shutdown, but now it's back up and compiz is looking really good.

 I'll see about tar.bz2 them all tomorrow and post to this site.

 Dave

Slicing and dicing the HD in a different way - NTFS, Fat32 and ZFS on B110

Hi All,

 So I thought I would  try something differnet on the AA1 10 inch, Fuse is pretty good for read and writting ntfs but it does seem to kill the netbook sometimes.

 With this new netbook I've sliced the disk this way:

40Gb - NTFS - Windows XP Home, still have to run iTunes

60Gb - Fat32 data

40Gb - ZFS - OpenSolaris Nevada (SXCE) B110

 I'm trying to setup everything so the data for my user is on the Fat32 partition even if it is Windows or OpenSolaris I'm booted into.

I can mount the Fat32 partition in OpenSolaris and I've link my user home directory to it.

So I'm building compiz 0.8.0, see if I can get the MSI to run it.

Found another bug in gnome-system-monitor, on my big Asus C90S powertop says:

 Cn            Avg    residency    P-states (frequencies)
C0 (cpu    running)        (8.4%)     1596 Mhz    100.0%
C1            3.9ms     (91.6%)     2394 Mhz    0.0%  

Wakeups-from-idle per second: 237.7     interval: 5.5s
Power usage (ACPI estimate): 0.000W

Top causes for wakeups:
67.6% (160.7)               <kernel> :    genunix`cv_wakeup
42.1% (    99.9)               <kernel> :    genunix`clock
21.4% (    50.8)                  sched :    <cross calls>
 6.5% (    15.4)               <kernel> :    uhci`uhci_handle_root_hub_status_change
 4.2% (     9.9)               <kernel> :    ata`ghd_timeout
 2.4% (     5.7)         <interrupt> :    ehci#0
 2.2% (     5.1)         <interrupt> :    ata#0
 1.9% (     4.4)               <kernel> :    uhci`uhci_cmd_timeout_hdlr
 1.7% (     4.0)               <kernel> :    genunix`schedpaging
 1.6% (     3.9)               <kernel> :    ehci`ehci_handle_root_hub_status_change


But gnome-system-monitor only shows one processor ?

So much to test, so little time :-)



Thursday Mar 19, 2009

Gnome system monitor 2.26 on OpenSolaris B110

Hi All,

So I've been waiting for this for a long time, thanks to the gnome engineering team we finally have what Ubuntu and Fedora has Gnome System Monitir above 2.18.2, not there fault, our compilers had some issues.

I usually do a pull from the OpenSolaris gnome trunk every week

svn co svn+ssh://anon@svn.opensolaris.org/svn/jds/spec-files/trunk

Last night I found we had updated gnome system monitor to 2.26, I had to build glib 2.20.0, libgtop 2.26 and gnome-system-monitor 2.26.0.

Not that it did not have any compile issues but it was worth it, these screenshots are of the AA1 10 inch.



Wednesday Mar 18, 2009

Netbook testing with OpenSolaris (SXCE) B110

Hi All,

 So development engineering and I have decided to standardize testing on SXCE, this is to give us a clear view into the OS, without any of the major changes that 0906 makes to the standard SXCE.

I have a new category now the new Acer Aspire One with the 10 inch screen. They made a few changes to the hardware, first it has an Atheros ethernet vs the Realtek ethernet the 8.9" has, second it has a single USB attached SD/MSpro card reader vs the two card slots on the 8.9" on the JMicron controller.

I left my original AA1 down in LA, so we are now focusing on making the AA1 8.9", AA1 10" and MSI 10" work with B110.

Most of yesterday we focused on the new power management built into B110, we needed to change a couple of entries in the /etc/power.conf and add a line into /etc/system.

/etc/power.conf

autopm            enable
autoS3            default
cpu-threshold        1s
cpupm              enable
S3-support         enable
system-threshold        15s
# Auto-Shutdown        Idle(min)    Start/Finish(hh:mm)    Behavior
autoshutdown        30        9:00 9:00        noshutdown

/etc/system

set cpupm_ti_gov_multiple = 5

I also found out that my old standby command kstat -m cpu_info -s current_clock_Hz only show you a single view of what the cpu is doing, powertop using a 5 second grap of the counters is the best way of finding out what the avarage cpu speed is.

We are now working on the sdcard issues on the AA1, also the USB sdcard issues on the AA1-10 and MSI.

You can see an sdcard or MSPro card inserted the first time, after you unmount, the card reader cannot be used again until the next reboot.

The MSI is now suspending and resuming and the cpu throttling is working after resume, the touchpad is still dead though.

I'm having major compiz problems on all the netbooks.

You can sometimes actually manually startup compiz, but the minute you logoff and try to login into the netbook again you just get a background and cursor, it never gets to the desktop.

I've also got the IGO1000 running 0906-B109 from the 8Gb CF, with 1Gb memory and Intel B/G Mini PCI-E wifi.

I'll replace with SXCE B110 sometime today.

Dave





Saturday Mar 14, 2009

OpenSolaris B110 on Acer Aspire One new 10 inch

Hi All,

  Back from CA trip, it was very productive.

  I typing this in on the new Acer Aspire One 10 inch version.

  I have B110 installed, interesting issues with disk partitioning.

  I'll blog more about the trip and this new Acer next week in detail

Dave

Wednesday Mar 11, 2009

IGoLogic IGO1000 embedded Intel Atom system and 0906-B107

Hi All,

 So I had a chance yesterday to play with a new IGoLogic system, the IGO1000.

 It has the Intel Atom N270 on board, it's the smallest system I've worked on so far.

 It took 0906-B107 without any issues at all. I did a USB boot, then installed to an 8Gb CF card.

 It has an Intel PCI-E wifi card installed also.

IGoLogic IGO1000

 You can check it out at:

http://www.igologic.com/products/Product.aspx?ProductID=108

Update 5/1/09

So I have Nevada B112 installed on a 8Gb CF, just ran HCTS it passed


Sunday Mar 08, 2009

Webbook agenda for next Thursday

Hi All

I'm wifi'd in to the network at the airport in Seattle, having this AA1 be able to do suspend / resume correctly is magic.

So this is our technical agenda for next week with Sun laptop engineering group. I've added the suggestion speed startup and shutdown times.

Any other items to do with hardware issues, please feel free to comment.

Dave

All

Startup and shutdown times

AA1

 SDCard driver needs to be completed

How to get MSPro working

Mapping FN keyboard correctly

Strange video interference when in Ekiga video conference software that does not happen on Cheese

Elonex

Not sure what state it's currently in Jan has got it

CPU processor cycling should be fixed

We will have to quickly test what's working again

This is a VIA C7 netbook

Mapping FN keyboard correctly

MSI

Processor walled at 1.6Ghz after resume, something is hogging CPU 1 not sure how to find out what it is doing it

Touchpad not working after resume

USB SD / MSPro card reader not being loaded and unloaded properly

Mapping FN keyboard correctly

RAlink wifi driver issues with suspend / resume, looks like MSI is using three different b/g/n wifi cards, I replaced with Atheros B/G

HP Netbook

Marvell driver issues (MYK)

NDISwrapper issues with suspend / resume (does not allow)

NWAM issues with NDISwrapper

Dark webcam under cheese program

Mapping FN keyboard correctly

DELL Mini9

I'm meeting a guy  in MPK Wednesday to help get his
DELL Mini9 working so we can add this to tested list

Will have to see what hardware it has.

AA1 10" version

I've ordered one of these but they are not in the USA (in black) yet

Changed the order to Blue should get it next Friday, hopefully it's exactly the same hardware as the 8.9" AA1 just bigger.

It does look like it has hatches on the bottom to change HDD, Memory or WiFi card, this will be much better.


Saturday Mar 07, 2009

Off to CA tomorrow with netbooks

Hi All,

So off to CA tomorrow, I'll be meting with Solaris X86 marketing about the netbooks, Thursday I'll be flying down to LA to meet with the Laptop enginering team.

I'll be taking the AA1, MSI and picking the Elonex back up in MPK.

We have a long list of issues to talk about, we are planning to pick a couple of netbooks to focus on, getting full Sun certification is the aim.

That way we will be able to create P1 bug reports if we need to.

Just upgrade my Asus C90S to B109 from B103.

Had some issues with compiz and the myk ethernet driver, but all fixed up now.

I"ll blog more from the road.

Monday Mar 02, 2009

Autoscan Network 1.41 on OpenSolaris

Hi All,

So my friend Tom Karbowski moved the ball down the field a ways with Autoscan Network 1.41 on OpenSolaris.

The screenshot is the GUI running with the network wizard.

This may take a little bit of time for us as the entire code is in French, a language Tom and I are not fluent in.

Funny how much you can get from code when it's in a language you understand.

Anyway we will keep trying to make it work.


Wednesday Feb 11, 2009

MSI and AA1 suspend / resume, OpenSolaris B107

Hi All,

So I've been working with the MSI and AA1 all day, tryiung to work out the issues with suspend / resume.

After going back to B104 on the MSI and getting suspend / resume working, finding out how to get the touchpad working after resume:

#/usr/bin/bash
MODID=`modinfo | grep mouse8042 | awk '{print $1}'`
pfexec modunload -i $MODID
pfexec modload /kernel/drv/mouse8042

Looks like you need to do it twice ???

I did a clean install of B107 onto the MSI, suspend / resume is working perfectly.

The AA1 with B107 started working also, then stopped, then started to suspend / resume, I think it maybe the sdcard driver, but I'm not sure.

They are both great netbooks, the MSI has the 10" screen, plus you can just take the bottom of and get to the HD, Memory and mini pci-e wifi card really easily.

The AA1 is a little smaller so works really well on the road and airplanes.

I love the both of them.

I'm sitting down in my media room, watching American Idol of the HD DVR, just did a VOD of a movie for the first time tonight in HD via DirectTV, at $5.99 it was better than buying a DVD.

I'm using Vinagre to connect to the MSI up in the lab, changing the look and feel.

The laptop I'm on has B107, it's the ECS laptop with the dual core 64 bit and Nvidia card, just spinning around the cube to the different desktops.

Off for a week of ski vacation on Friday, the ski hill here in Washington got 7" snow last night :-)

My wife and 9 year old grand daughter will probably leave me in the powder.


Monday Feb 02, 2009

Acer Aspire One with OpenSolaris B107, everything works

Hi All,

Just did a clean install of B107 to the AA1.

Wiped out the previous OpenSolaris install.

Sun only started the project to certify this platform two and a half months ago, now i don't add any drivers during or after install.

You do have to update the /etc/power.conf

Suspend / resume works great.

You will get warning messages from the sdcard driver if you don't have sdcards in the slots.

So:

ethernet works

wifi works

webcam works

audio works, internal speakers and head phone jack

suspend / resume works

sdcard works, I just found out you need to put an sdcard in the right one first, then they both work all the time

USB works

Externel VGA works, shift + F5 to jump between the two of them

Pretty cool

Thanks to all the great Sun engineers who put up with me bugging them to get the drivers working, and all the great users who help test them out.

Saturday Jan 31, 2009

OpenSolaris Download Links

http://opensolaris.org/os/downloads/
About

I work for the Java Embedded Global Business Unit of Oracle within Java Industry Solutions group under Alliances and Channels . I'm focused on the Java SE Embedded and BDB for ARM and PPC across multiple verticals

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today