OpenSolaris SDCard driver for Acer Aspire One - here

Hi All,

Here is the Alpha Release tar file for the SDCard driver for OS .

tar xvf SUNWsdcard.tar

pkgadd -d .

init 6

Now you should be able to insert sdcards in either slot.

Have fun

Dave

Comments:

Great! I'm testing this right now on osol-200811 and the left memory reader (aka storage expander) works great, still no luck with the right one. Now if i could just synch my ipod touch with itunes in a vbox i'll be ready to use opensolaris as main os =)
Thank you for your efforts!

Posted by youth against youth on December 30, 2008 at 09:54 PM PST #

Hi,

I had the same problem until I started up the machine with card in that slot, then it worked, mount and unmount.

Yes, I'm waiting for USB in VirtualBox also :-)

Dave

Posted by David Clack on December 30, 2008 at 10:36 PM PST #

OK, now I've got both of theme working, next step: Suspend/Resume
I've tried you power.conf but when I try to suspend it hangs displaying garbage on screen..maybe an issue with the GME driver?

Posted by youth against youth on December 31, 2008 at 12:32 AM PST #

Weird, mine suspends and resumes fine.

I'll post my xorg.conf and power.conf tonight

Dave

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11/lib/X11/rgb"
ModulePath "/usr/X11/lib/modules"
FontPath "/usr/X11/lib/X11/fonts/TrueType/"
FontPath "/usr/X11/lib/X11/fonts/Type1/"
FontPath "/usr/X11/lib/X11/fonts/Type1/sun/"
FontPath "/usr/X11/lib/X11/fonts/F3bitmaps/"
FontPath "/usr/X11/lib/X11/fonts/misc/"
FontPath "/usr/X11/lib/X11/fonts/100dpi/"
FontPath "/usr/X11/lib/X11/fonts/75dpi/"
FontPath "/usr/X11/lib/X11/fonts/dejavu-ttf-2.9/"
FontPath "/usr/X11/lib/X11/fonts/msttcorefonts/"
EndSection

Section "Module"
Load "glx"
Load "xtsol"
Load "dbe"
Load "record"
Load "dri"
Load "extmod"
Load "GLcore"
Load "IA"
Load "xtrap"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
#DisplaySize 200 110 # mm
Identifier "Monitor0"
VendorName "AUO"
ModelName "11c2"
Option "DPMS" "True"
EndSection

Section "Monitor"
#DisplaySize 200 110 # mm
Identifier "Monitor1"
VendorName "AUO"
ModelName "11c2"
Option "DPMS" "True"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "ColorKey" # <i>
#Option "CacheLines" # <i>
#Option "Dac6Bit" # [<bool>]
#Option "DRI" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "XvMCSurfaces" # <i>
#Option "PageFlip" # [<bool>]
Identifier "Card0"
Driver "intel"
VendorName "Intel Corporation"
BoardName "Mobile 945GME Express Integrated Graphics Controller"
BusID "PCI:0:2:0"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "ColorKey" # <i>
#Option "CacheLines" # <i>
#Option "Dac6Bit" # [<bool>]
#Option "DRI" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "XvMCSurfaces" # <i>
#Option "PageFlip" # [<bool>]
Identifier "Card1"
Driver "intel"
VendorName "Intel Corporation"
BoardName "Mobile 945GME Express Integrated Graphics Controller"
BusID "PCI:0:2:1"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Virtual 2048 1600
Depth 24
Modes "1650x1050" "1400x1050" "1280x1024" "1024x600" "800x800"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Card1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Virtual 2048 1600
Depth 24
Modes "1650x1050" "1400x1050" "1280x1024" "1024x600" "800x800"
EndSubSection

EndSection

Posted by David Clack on December 31, 2008 at 04:05 AM PST #

Turns out I wasn't using any xorg.conf at all, trying your xorg.conf posted above resulted in x not starting with a DRI error

(II) intel(0): I830CheckAvailableMemory: 257012 kB available
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: open result is -1, (No such device or address)
drmOpenDevice: Open failed
[drm] failed to load kernel module "i915"
(II) intel(0): [drm] drmOpen failed
(EE) intel(0): [dri] DRIScreenInit failed. Disabling DRI.
(\*\*) intel(0): Framebuffer compression enabled
(\*\*) intel(0): Tiling enabled
(==) intel(0): VideoRam: 262144 KB
(II) intel(0): Attempting memory allocation with tiled buffers.
(II) intel(0): xf86AcquireGART: AGPIOC_ACQUIRE succeeded

The gdm goes in maintainance mode. svcadm clean gdm, svcadm restart gdm give me a usuable login screen (WEIRD), issuing a suspend returns to the console login but this time i've got something logged on /var/adm/messages

Jan 2 16:00:23 nosferatu gnome-session[1563]: [ID 702911 daemon.warning] WARNING: Could not connect to ConsoleKit: Could not get owner of name 'org.freedesktop.ConsoleKit': no such name
Jan 2 16:00:28 nosferatu genunix: [ID 535284 kern.notice] System is being suspended
Jan 2 16:00:29 nosferatu genunix: [ID 122848 kern.warning] WARNING: Unable to suspend device display@2.
Jan 2 16:00:30 nosferatu genunix: [ID 537702 kern.warning] WARNING: Device is busy or does not support suspend/resume.

Jan 2 16:00:51 nosferatu gnome-session[1563]: [ID 702911 daemon.warning] WARNING: Could not ask power manager to suspend: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

I've got a white screen instead of garbage but still no suspend and i need to reboot from ssh to have back an usable system.
Since I'm running OSOL-2008.11 and not SXCE (build 101b against 104) I'm thinking about an issue with the drivers..

Posted by youthagainstyouth on January 01, 2009 at 11:24 PM PST #

UPDATE:

root@nosferatu:~# devfsadm -i i915
devfsadm: driver failed to attach: i915
root@nosferatu:~#

Jan 2 17:25:52 nosferatu gfx_private: [ID 239156 kern.warning] WARNING: gfxp_vgatext: can't find reg entry for registers
Jan 2 17:25:52 nosferatu genunix: [ID 276693 kern.warning] WARNING: drm_supp_regiter: failed to init gfx
Jan 2 17:25:52 nosferatu genunix: [ID 112014 kern.warning] WARNING: i915_attach: drm_supp_register failed
Jan 2 17:25:52 nosferatu sdhost: [ID 851180 kern.warning] WARNING: Failed to map registers!
Jan 2 17:25:52 nosferatu sdhost: [ID 852830 kern.warning] WARNING: Failed initializing slot 0
Jan 2 17:25:52 nosferatu pcplusmp: [ID 444295 kern.info] pcplusmp: ide (ata) instance #1 vector 0xf ioapic 0x4 intin 0xf is bound to cpu 0

Posted by youthagainstyouth on January 02, 2009 at 12:27 AM PST #

Hi,

Looks like you probably had vesa driver, did you download the patched i915 from my ftp site ?

I'll try to post them again on my website.

Dave

Posted by David Clack on January 02, 2009 at 02:01 AM PST #

I've used the drivers you've mailed me :)

Posted by Youth against youth on January 02, 2009 at 04:10 AM PST #

youthagainstyouth:

update_drv -a -i ‘”pci8086,27ae″‘ i915 (remove older lines in /etc/driver_aliases) and reboot, must work.

I have installed osol2008.11 in my AA1 (SSD version) with David's drivers and all is working fine (but not resume-from-X/Window)

Thank you very much for the sdcard driver!

Posted by Iban on January 04, 2009 at 06:31 AM PST #

Post a Comment:
  • HTML Syntax: NOT allowed
About

I work for the Java Embedded Global Business Unit of Oracle within Java Industry Solutions group under Alliances and Channels . I'm focused on the Java SE Embedded and BDB for ARM and PPC across multiple verticals

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today