OpenSolaris B111 on AA1

Hi All,

So somehow I screwed up an luugrade on the AA1, I've ended up doing a clean install of B111.

Apart from having to install the DRM patch, which should hit the next build B112, everything works great.

Compiz, suspend/resume, ethernet, wifi, even the two SDcard slots are coming up without all the errors at boot.

Shutdown is really fast.

I've found that ccsm to config compiz is having pygobject errors, if you just rebuild it ccsm works fine, I opened a P1 bug on it today.

Tom has ported Autoscan Network 1.42, I'll try and get it onto the new data store tomorrow.

Dave

Comments:

Good news.
Did everything just work out of the box or did you have to do any tweaks?

Best Reg

--akeh

Posted by Ake Hjalmarsson on March 31, 2009 at 04:08 PM PDT #

Hey Dave,

Just need to sort Solaris boot times out now.. Linux is down to 3sec odd on Netbooks now and Solaris is like a 60-120sec !
That's 20-40times slower !

Regards,

Posted by EdwardO'Callaghan on March 31, 2009 at 11:21 PM PDT #

Hi,

I had to put the DRM patch in, plus the xorg.conf to get compiz to work every time.

plus the power.conf and /etc/system patch

power.conf

device-dependency-property removable-media /dev/fb
autopm default
autoS3 default
cpu-threshold 1s
S3-support enable
cpupm enable
# Auto-Shutdown Idle(min) Start/Finish(hh:mm) Behavior
autoshutdown 30 9:00 9:00 noshutdown

/etc/system line

set cpupm_ti_gov_multiple = 5

xorg.conf

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "AllowEmptyInput" "off"
EndSection

Section "Files"
FontPath "/usr/X11/lib/X11/fonts/misc/:unscaled"
FontPath "/usr/X11/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11/lib/X11/fonts/misc/"
FontPath "/usr/X11/lib/X11/fonts/Type1/"
FontPath "/usr/X11/lib/X11/fonts/100dpi/"
FontPath "/usr/X11/lib/X11/fonts/75dpi/"
FontPath "/usr/X11/lib/X11/fonts/TrueType/"
FontPath "/usr/X11/lib/X11/fonts/F3bitmaps/"
FontPath "/usr/X11/lib/X11/fonts/msttcorefonts/"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "IA"
Load "bitstream"
Load "xtsol"
Load "glx"
Load "freetype"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/mouse"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "CMO"
HorizSync 30.0 - 75.0
VertRefresh 60.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "Acer AL2216W"
HorizSync 31.0 - 84.0
VertRefresh 56.0 - 77.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Device"

# Option "HWCursor" "1"
# Option "NvAGP" "1"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8600M GT"
Option "NoTwinViewXineramaInfo" "1"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"

# Option "HWCursor" "1"
# Option "NvAGP" "1"
Identifier "Videocard1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8600M GT"
Option "NoTwinViewXineramaInfo" "1"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP: nvidia-auto-select +0+0"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "DigitalVibrance" "128"
Option "NoLogo" "1"
Option "CursorShadow" "1"
Option "CursorShadowXOffset" "4"
Option "CursorShadowYOffset" "2"
Option "CursorShadowAlpha" "100"
Option "MergedDPI" "96 110"
Option "TwinView" "0"
Option "metamodes" "DFP-0: nvidia-auto-select +0+0"
Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 24
Modes "nvidia-auto-select" "nvidia-auto-select" "nvidia-auto-select"
EndSubSection
EndSection

Section "Screen"

# Removed Option "metamodes" "CRT: nvidia-auto-select +0+0"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
Option "DigitalVibrance" "128"
Option "NoLogo" "1"
Option "CursorShadow" "1"
Option "CursorShadowXOffset" "4"
Option "CursorShadowYOffset" "2"
Option "CursorShadowAlpha" "100"
Option "MergedDPI" "96 110"
Option "TwinView" "0"
Option "metamodes" "DFP-1: nvidia-auto-select +0+0"
Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 24
Modes "nvidia-auto-select" "nvidia-auto-select" "nvidia-auto-select"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
Option "RENDER" "Enable"
EndSection

Posted by David Clack on April 01, 2009 at 12:39 AM PDT #

Hi, I'm trying to get b111 onto my AA1 using the USB image from genunix.org but am having trouble. After booting from the USB drive Gnome starts up but the system slows to a crawl and I'm unable to even double-click the installer (or any other) icon. The pointer moves, albeit sluggishly.

My AA1 is the 512MB flash memory model. Am I on a hiding to nothing?

Thanks :\^)

Posted by mark hellewell on April 14, 2009 at 09:32 AM PDT #

Hi, I'm trying to get b111 onto my AA1 using the USB image from genunix.org but am having trouble. After booting from the USB drive Gnome starts up but the system slows to a crawl and I'm unable to even double-click the installer (or any other) icon. The pointer moves, albeit sluggishly.

My AA1 is the 512MB RAM + 8GB flash memory model. Am I on a hiding to nothing?

Thanks :\^)

Posted by mark hellewell on April 14, 2009 at 09:33 AM PDT #

Hi,

I'm doing SXCE installs from USB / DVD, not OpenSolaris.

I've got 1Gb memory and HDD.

I tries 0906.B109 usb it worked

Downloaded B111 used usbcopy to get it to same usb stick.

GUI has just started up fine. Pointer is moving normally, installer started fine.

Dave

Posted by David Clack on April 14, 2009 at 10:26 AM PDT #

Post a Comment:
  • HTML Syntax: NOT allowed
About

I work for the Java Embedded Global Business Unit of Oracle within Java Industry Solutions group under Alliances and Channels . I'm focused on the Java SE Embedded and BDB for ARM and PPC across multiple verticals

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today