Building Evolution 2.29.90 on B132

Hi All,

 So I got busy working on another couple of projects and had put of trying do more than small builds on B132.

This weekend I decided to tackle Evolution 2.29.90, my first try I downloaded the trunk spec files, using the specs to hand patch the evolution-data-server and evolution source.

I hit the first problem in evolution-data-server, an undefined variable called altzone, not sure where this comes from even now, not sure why it's not in B132, found a definition in another  piece of OpenSolaris code, popped it in worked perfect.

I even tried using the pkgbuild -ba on the spec files, it always used to work. This time I hit issues with build requirements for packages that do not show up in the package repository, SUNWgtkimageview being one of them needed by Evolution.

After half a day, I had everything built, fired up Evolution, it stretched over three of my compiz screens (could never get it to stop doing this), the all day events stretched over two days.

Conclusion, put 2.28.2 back onto the system, 2.29.90 will have to wait for awhile :-)

Dave


Comments:

Did you per any chance build evolution with mapi enabled? I miss that in the shipped evolution :(

Posted by Andreas Nilsson on February 15, 2010 at 02:55 PM PST #

My ./configure for evolution and evolution-data-server 2.29.90

./configure --prefix=/usr --disable-static --disable-gtk-doc --enable-maintainer-mode --enable-ssl=yes --enable-smime=yes --enable-file-chooser --enable-nntp=yes --with-nspr-libs=/usr/lib/mps --with-nss-libs=/usr/lib/mps --with-nss-includes=/usr/include/mps --with-nspr-includes=/usr/include/mps --disable-gtk-doc --with-openldap --with-x --enable-ipv6=yes --enable-nss=yes --localstatedir=/var --libexecdir=/usr/libexec --with-libiconv=/usr/gnu --with-krb4=/usr --with-libiconv=/usr/gnu --disable-nm --with-weather --disable-pst-import

Evolution-data-server

./configure --prefix=/usr --disable-static --disable-gtk-doc --enable-maintainer-mode --enable-ssl=yes --enable-smime=yes --enable-file-chooser --enable-nntp=yes --with-nspr-libs=/usr/lib/mps --with-nss-libs=/usr/lib/mps --with-nss-includes=/usr/include/mps --with-nspr-includes=/usr/include/mps --disable-gtk-doc --with-openldap --with-x --enable-ipv6=yes --enable-nss=yes --localstatedir=/var --libexecdir=/usr/libexec --with-libiconv=/usr/gnu --with-krb4=/usr

Posted by David Clack on February 15, 2010 at 10:42 PM PST #

Me too.

Posted by Larry Wagner on February 16, 2010 at 11:39 AM PST #

Hi Guys,

You want mapi in Evolution 2.28.2, the one that ships with build 132 ?

No guarantees it actually works :-)

I'll see if I can build the two packages tomorrow.

Dave

Posted by David Clack on February 16, 2010 at 12:35 PM PST #

Yepp, that would be splendid ;) The evolution website claims it should be a standard component now.

Posted by Andreas Nilsson on February 16, 2010 at 08:35 PM PST #

Post a Comment:
  • HTML Syntax: NOT allowed
About

I work for the Java Embedded Global Business Unit of Oracle within Java Industry Solutions group under Alliances and Channels . I'm focused on the Java SE Embedded and BDB for ARM and PPC across multiple verticals

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today