X

An Oracle blog about Oracle Coherence

Oracle Coherence 12.2.1.4.0 Released!

Randy Stafford
Senior Manager

Oracle Coherence Product Development is pleased to announce the release of Oracle Coherence 12.2.1.4.0 into general availability.

Oracle Coherence 12.2.1.4.0 is now available for downloading at https://www.oracle.com/middleware/technologies/coherence-downloads.html, and its documentation is online at https://docs.oracle.com/en/middleware/fusion-middleware/coherence/12.2.1.4/index.html.

Important new features in Oracle Coherence 12.2.1.4.0 include the following:

  • Docker and Kubernetes Certification: Coherence applications can be deployed in Docker images orchestrated with Kubernetes, as now covered in the Administering Oracle Coherence documentation book.
  • Coherence Metrics: a metrics endpoint enabling metrics gathering systems like Prometheus to gather metrics from each cache server over HTTP in text or JSON format.
  • REST Management: Coherence now supports management operations using REST, with Coherence MBeans exposed as REST resources.
  • View Caches: a new recommended alternative to replicated caches, combining comparable read performance with partitioned cache consistency, safety, and persistence characteristics.
  • Quorum Policies: new cluster quorum policies are available for mandating the minimum number of members that must be present before terminating a member.
  • Password Providers: password providers allow you to plug in your own mechanism to provide the passwords are required as part of SSL socket provider configuration.
  • Netty Support: Coherence REST can now be configured to use the Netty HTTP server.

Oracle Coherence 12.2.1.4.0 will be the long-term support patch set in the Oracle Coherence 12.2.1 line, meaning future releases in this line will be limited to patch set updates (increments of the last digit of the release number).

Oracle Coherence Product Development encourages users of Oracle Coherence 12c and earlier versions to upgrade to Oracle Coherence 12.2.1.4.0. 

Join the discussion

Comments ( 2 )
  • Carlos Viton Monday, September 30, 2019
    Hi Randy.
    I don't see in changelog nothing about if OpenJDK (version 11) is supported in this version.
    Can you resolve this question?
    Regards
  • Randy Stafford Monday, September 30, 2019
    Hi Carlos,

    The official certification matrix is at https://www.oracle.com/technetwork/middleware/ias/downloads/fusion-certification-100350.html.

    Under product area "Oracle Fusion Middleware 12c Certifications", open the xls for bullet "System Requirements and Supported Platforms for Oracle Fusion Middleware 12c (12.2.1.4.0)." On the "System" tab you can see the JVMs supported per processor and OS for each Fusion Middleware product.

    In general Coherence 12.2.1.4 is certified with Oracle JDK 8, and certain HP and IBM version 8 JDKs.

    In release 14.1.1, which is already in beta, Coherence is certified with Oracle JDK 11.

    Cheers,
    Randy
Please enter your name.Please provide a valid email address.Please enter a comment.CAPTCHA challenge response provided was incorrect. Please try again.