X

The latest Oracle Database news and guidance from the development team

Patching maybe required for older versions of the Oracle Database using database links

Dominic Giles
Master Product Manager

If you're running an older version of the Oracle Database and are actively using database links to connect to other databases, regardless of their version, you may need to take action to ensure your database applications continue to work as expected. We are strongly encouraging users of these older databases to consider upgrading, or at a minimum checking that they have had the latest patches applied to them.

The issue may effect Oracle databases with the following version numbers

  • 10g release 2 (10.2.0.5 and lower)
  • 11g release 1 (11.1.0.7 and lower)
  • 11g release 2 (11.2.0.3 and lower)
  • 12c release 1 (12.1.0.1)

There are detailed descriptions of what versions are effected and the available patches detailed in the support note DOC ID 2335265.

If you are on one of the following versions of the database this issue won't effect you.

  • 11g release 2 (11.2.0.4)
  • 12c release 1 (12.1.0.2)
  • 12c release 2 (12.2.0.1)
  • 18c
  • 19c

If you don't patch your database to the level recommended and continue to use database links then it is possible that at some time after June 23rd 2019 that these links will not be able to be established.

If you have any questions relating to this subject please ask them on this community forum