Java versions for Agents

I recently saw a question from the field regarding Agent installation:

"I'm trying to manage a group of servers with Ops Center. They use Java 1.5; is that going to be a problem?"

No, it shouldn't be. The Ops Center Agent uses Java 1.6, but it will install Java 1.6 if it's not already there. Java 1.5 and 1.6 can coexist on your systems. As long as Ops Center can get to Java 1.6 in the default location, it should work fine.

Comments:

People should be aware that there is a minimum version of Java 1.6 that Ops Center Agent will use, and that it will automatically upgrade Java 1.6. This could be an issue if there are applications using the OS supplied copy of Java 1.6 and are expecting a specific version (hardcoded path for 1.6 or extra jar files added, etc.)

For Agent version 12.2.0.2663 it will install 1.6.0_65

It will potentially also install 13 patches and 36 packages for a Solaris 10 Sparc box. Running the installer locally with "-n -v" will do a verbose dry-run - would really like this to be an option when discovering/managing a server so the potential impact can be seen.

Posted by guest on July 18, 2014 at 12:44 PM MDT #

Post a Comment:
  • HTML Syntax: NOT allowed
About

This blog discusses issues encountered in Ops Center and highlights the ways in which the documentation can help you

Search

Archives
« April 2015
SunMonTueWedThuFriSat
   
1
3
4
5
6
7
8
10
11
12
13
14
15
17
18
19
20
21
22
24
25
26
27
28
29
30
  
       
Today