Tuesday Jul 23, 2013

Provisioning Different Versions of Oracle Solaris 11

I got a couple of questions about the new support for multiple Automated Installer (AI) releases in 12.1.4:

"How do I set up different versions of Oracle Solaris 11 in the Solaris 11 Software Library? For example, I want to use these versions for OSP:

  • Solaris 11/11 SRU 5.5
  • Solaris 11.1 SRU 8.4

So how do I get both of them into my library and ready for OSP use?"

There are a couple of ways. The first is to configure the parent repository to use a source with both of those releases. If you haven't initialized your library, configuring the parent repository is part of the library creation; otherwise it's a separate job, which you can set to repeat according to a schedule.

The other way is to use the Add Content wizard to add a specific S11 release to your library. This action doesn't save the parent repository location, but it works well if you're adding a specific version.

Once your S11 library has the content for both releases, you'll be able to create OSP profiles for either one. There's a dropdown option that lets you pick which version of S11 you want to use:


"I have my library using a valid repository, but the new versions aren't showing up in the OSP wizard. Do I need to restart the Enterprise Controller to make them show up?"

If the new versions aren't showing up, re-running the library sync job should make them appear. You shouldn't have to restart the EC.

Once you've done these steps, you can provision these versions of S11 from any of your Proxy Controllers.

About

This blog discusses issues encountered in Ops Center and highlights the ways in which the documentation can help you

Search

Archives
« July 2013 »
SunMonTueWedThuFriSat
 
1
3
4
5
6
7
8
10
11
12
13
14
15
17
18
19
20
21
22
24
26
27
28
29
30
31
   
       
Today