Issue #145913 - Historically the Most Heavily Voted NetBeans Issue

It's almost two weeks ago when I published entry Support for Cake PHP, Symfony, Prado, Zend Framework, Smarty or ... ? where I invited PHP developers to vote for their favorite PHP framework. The most voted frameworks will be supported in the next version of NetBeans. The voting will be closed after NetBeans 6.5 is finished and published, so there are still a few weeks for voting.

Current voting is following (at 9 am CEST, 15th September) :

So far there are more than 4 hundred votes mainly due to votes for Symfony. In this moment issue #145913 is the top voted NetBeans Issuzilla entry ever. Also based on comments in this issue I have added YAML support to the NetBeans PHP.

Comments:

Symfony is so popular? Why ? I dislike the "sf" prefix everywhere at my first look.

Smarty is a template technique in PHP , not as framework.

Posted by hantsy on September 15, 2008 at 03:33 AM CEST #

well, I wouldn't call this represantative, since this was organized by the symfony community:

http://www.symfony-project.org/blog/2008/09/11/support-symfony-inclusion-in-netbeans

Posted by Dane on September 15, 2008 at 11:21 AM CEST #

I know about this. On the other hand similar announcements you can find for CakePHP or Prado as well.

Regards,
Petr

Posted by Petr on September 15, 2008 at 12:28 PM CEST #

I think the first thing to do is making the PHP support is more powerful(including javascript and html support ) and more flexiable for end user.

Posted by hantsy on September 16, 2008 at 10:29 AM CEST #

People voice.... God voice !!!

Posted by Odair on October 01, 2008 at 06:56 AM CEST #

@Dane
You are SO wrong...the symfony community didn't organized this. Just promoted it on their site.
Cake, Prado and Zend communities could have do the same.
The truth is, Symfony is a great framework with a really huge community. I'm very glad for these news, and of course they have my vote.

Posted by mppfiles on November 15, 2008 at 07:17 AM CET #

Hi there

If this would be open again I would vote for Zend Framework.

Gruss
Silvio

Posted by Suvi on March 12, 2009 at 10:52 AM CET #

I would vote for Zend Framework AND Smarty. I think that they are two 'must' to support because the use of them is overwhelming. In third place I would vote support for symfony, the best php framework 'out the box' imho.

Posted by meigallodixital on June 30, 2009 at 04:46 PM CEST #

Guess voting is finished now, but not having smarty working is a killer. I trying out netbeans as a replacement for eclipse but as of 6.71 no smarty means i can only spend half my time getting used to netbeans at best.

Im finding i have eclipse and netbeans open and come over to netbeans for the ctrl+shift+space functionality then go back and implement in eclipse. ugly workflow.

Posted by ussher on August 26, 2009 at 10:39 PM CEST #

Smarty pls, I need it
Thanks

Posted by Luuuc on January 18, 2010 at 03:20 PM CET #

Post a Comment:
  • HTML Syntax: NOT allowed
About

This blogs is written by NetBeans developers who contribute to the PHP support mainly.

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today