J2EE 5 project and Mobility Pack 5.5

NetBeans 5.5 Beta 2 supports the Java Enterprise Edition 5 platform, and most notably the Java Persistence, EJB 3 and JAX-WS 2.0 specifications.

Mobility Pack has two wizards for connecting to a server (more about them).
  • J2ME Web Service Client - generates client using Webservices API (JSR172).
  • Mobile Client to Web Application - generates a server part and a client part that communicates together. You can generate mobile clients to Webservice client too.
You can use J2ME Web Service Client for whatever webservice (JAX-RPC, JAX-WS 2.0) that is WS-I compliant. The wizard needs only the WSDL url/file.
The Mobile Client to Web Application needs an Web Application with webservice client, a class or a servlet that will provide data to it. Unfortunatelly the Mobile Client to Web Application doesn't work with JAX-WS 2.0 webservice clients. The wizard won't show you any webservice client that is created in J2EE 5 web project.


This situation has easy workaround. Create new Web project but the J2EE version has to be different than Java EE 5. For not J2EE 5 webservice clients you can use the Mobile Client to Web Application wizard .



There has been bug reported for this problem. It will not be fixed for 5.5 release. It is noticed in Release Notes.
Comments:

Post a Comment:
  • HTML Syntax: NOT allowed
About

This is the main channel to share news, tips and other stuff related to my work. Sometimes you can find even personal stuff. Enjoy your reading...

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today
news
Blogroll

No bookmarks in folder

OldNews
MyTrash
NavBar
NetBeans
LinksToBeExpanded