Netbeans 6.1, Java 6 and Mac OS

One of my customer was having an issue running Netbeans 6.1 beta on Mac OS with Java 6. Here is his response on how he resolved the SDK error issue. Thanks Rica.

Just wanted to let you know that I have finally found a way to run NB 6.1 Beta with Apple's Java 6SE DP9. The reported error on gui wizards was due to some Java 6 classes that were loaded into Java 5.

The trick is simple: go to the install directory of NB6.1 and point the netbeans_jdkhome variable to Java 6. In my case the configuration file is:
/Applications/NetBeans/NetBeans 6.1 Beta.app/Contents/Resources/NetBeans/etc/netbeans.conf

The line that needs to be modified is this:
# Default location of JDK, can be overridden by using --jdkhome

:
netbeans_jdkhome=/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home

Comments:

The problem is caused by the /System/Library/Java/Extensions/AppleScriptEngine.jar which contains Java 6.0 class files but it's located into the common extension folder shared by both JDK 5.0 and JDK 6.0.
Other solution is to move it into /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib/ext.

There is a discussion about this problem in the following NetBeans issue: http://www.netbeans.org/issues/show_bug.cgi?id=129227

Posted by Tomas Zezula on March 26, 2008 at 06:17 AM EDT #

Post a Comment:
  • HTML Syntax: NOT allowed
About

leroyk

Search

Categories
Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today