MacBook Pro, VirtualBox, and OpenSolaris

OpenSolaris was a big part of CommunityOne this year and as I mentioned in blogging about it, I was installing it and would be blogging about it soon. Well, it isn't as soon as I wanted (something about Java CAPS 6 has kept me busy) but here is an update of where I've gotten.

I'm running on a Mac, so went the route of installing OpenSolaris 200805 in VirtualBox 1.6. Getting and installing VirtualBox was straightforward, and then installing OpenSolaris also went very well. This blog entry goes into a bunch of detail on an identical type of configuration so I won't attempt to capture it all here again.

After the install, I wanted to get the desktop to use the full screen real estate I have and so went about finding out how to do that. Followed the steps and voila I can run full screen and have it appear that I have running OpenSolaris natively on the Mac.

So far I've installed OpenOffice.org via IPS which went just fine, and I'll be looking to install more things soon.

My outstanding issue is that I don't have audio working yet. By default audio was disabled in VirtualBox so I enabled it and tried both options it presents there but OpenSolaris hasn't recognized either. If anyone has any tips, please let me know.

I have also started installing OpenSolaris on a spare Dell D600 I have. I had LinuxMint on it already (Ubuntu based distro) and when I was done installing I could no longer boot to Linux! I found this blog that explained how to put the Linux Grub back and have it provide for booting to OpenSolaris which worked fine. I haven't gotten wireless working on it yet so that is the next project (any tips welcome!)
Comments:

Post a Comment:
  • HTML Syntax: NOT allowed
About

kevinschmidt

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today