How to integrate Java ME SDK 3.2 with Eclipse

Here is also an instruction on how you can integrate Java ME SDK 3.2 with Eclipse. You need additional steps for Eclipse Juno, because it does automatically detect and download MTJ (Mobile Tools for Java) plugin. The following instruction is for Eclipse Indigo.

1. Download Java ME SDK and Eclipse plugins from here.

2. Install Java ME SDK

3. Launch Eclipse

4. Go to "Help" - "Install New Software"

5. Click "Archive", and choose the Eclipse Plugin zip file you downloaded. Name is something like "Java ME SDK Plugin"

6. Choose Java ME SDK Tools, and select "Next".

7. It will calculate requirements and dependencies. Simply follow the instruction.

8. You may also have to manually install the platform. Check out "Help" - "Preferences" - "Java ME" - "Device Management". If you do not see Java ME SDK 3.2 devices, click "Manual Install" on the right side, and specify the folder where Java ME SDK is installed. By default, it is installed at "C:\Java_ME_platform_SDK_3.2".

9. You're done. Now you can use the Java ME SDK plugins for Eclipse.

Comments:

Hi,
I've downloaded the latest JavaME (3.2), installed on my computer and tried to integrate with my Eclipse (Juno).
After following the instructions, I can see MTJ is installed on the system, but in the Preferences window, there is no Java ME option to configure it.
thank you very much if someone can help me to solve this issue.

Posted by Marcel on November 28, 2012 at 06:37 AM PST #

“The operation cannot be completed. See the details.”

Details:Cannot complete the install because one or more required items could not be found.

/////Why?

Posted by guest on December 16, 2012 at 11:09 PM PST #

Cannot complete the install because one or more required items could not be found.
Software being installed: Java ME SDK Demos 1.0.0.201209212258 (com.oracle.jme.toolkit.demos.feature.group 1.0.0.201209212258)
Missing requirement: Java ME SDK Demos 1.0.0.201209212258 (com.oracle.jme.toolkit.demos.feature.group 1.0.0.201209212258) requires 'org.eclipse.mtj.feature.group 0.0.0' but it could not be found

Posted by guest on January 10, 2013 at 11:32 PM PST #

It didn`t work for me also. I had to move back to Indigo

Posted by guest on January 22, 2013 at 08:41 AM PST #

Eclipse Juno The Oracle Java ME SDK requires the MTJ toolkit, but it is not bundled with Juno and it must be installed manually. Therefore, install MTJ toolkit first.

1 Go to Help > Install New Software.
2 In the "Work with" field, enter this URL: http://download.eclipse.org/releases/indigo
3 Click Add. When the plugins are discovered, open the Mobile and Device Development Tools hierarchy and check Mobile Tools for Java, Mobile Tools for Java SDK, and Mobile Tools for Java Examples. Click Next. On the installation screen select all plugins and click Finish.
4 A Juno plugin named org.eclipse.jetty.server_(version).jar conflicts with the MTJ libraries when the plugin version is higher than 6. If it is you must prevent it from loading by changing its name so the Jar file is not parsed. For example, change it to: org.eclipse.jetty.server.old

Posted by guest on March 06, 2013 at 10:05 AM PST #

Juno plugin named org.eclipse.jetty.server_.jar conflicts with the MTJ libraries when the plugin version is higher than 6.
rename it to org.eclipse.jetty.server_.old solve the problem

Posted by issamux on April 01, 2013 at 07:40 PM PDT #

Post a Comment:
  • HTML Syntax: NOT allowed
About

Java ME Platform SDK is a toolbox for developing mobile applications. Java ME SDK Download

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today