Allocation 13.2.x , login fails and an Internet Explorer Error 500 is displayed

Issue: After upgrade/new install of 13.2.5 of allocation. Application does not login and display IE 500 error.

Logs file indicates below error stack 

Error:

.... com.oracle.retail.integration.common.security.credential.CredentialStoreManager getUserName

SEVERE: Unable to obtain the userName for the given key/userNameAlias(dsAlias).

java.security.AccessControlException: access denied (oracle.security.jps.service.credstore.CredentialAccessPermission context=SYSTEM,mapName=alloc13,keyName=dsAlias read)

    at java.security.AccessControlContext.checkPermission(AccessControlContext.java:374)

    at java.security.AccessController.checkPermission(AccessController.java:546)

    at oracle.security.jps.util.JpsAuth$AuthorizationMechanism$3.checkPermission(JpsAuth.java:458)

    at oracle.security.jps.util.JpsAuth.checkPermission(JpsAuth.java:518)

    at oracle.security.jps.util.JpsAuth.checkPermission(JpsAuth.java:544)

    at oracle.security.jps.internal.credstore.util.CsfUtil.checkPermission(CsfUtil.java:644)

    at oracle.security.jps.internal.credstore.ssp.SspCredentialStore.getCredential(SspCredentialStore.java:430)

    at com.oracle.retail.integration.common.security.credential.CredentialStoreManager.getUserName(CredentialStoreManager.java:879)

    at com.retek.alloc.security.AllocCredentialStoreAccessor.getUserName(AllocCredentialStoreAccessor.java:51)

    at com.retek.alloc.utils.ConnectionPool.getUsernameString(ConnectionPool.java:507)

    at com.retek.alloc.utils.ConnectionPool.configDSConnection(ConnectionPool.java:225)

    at com.retek.alloc.utils.ConnectionPool.initializeConnectionCacheDataSrc(ConnectionPool.java:201)

    at com.retek.alloc.utils.ConnectionPool.init(ConnectionPool.java:110)

    at com.retek.alloc.utils.ConnectionPool.createConnectionPoolObj(ConnectionPool.java:397)

    at com.retek.alloc.utils.ConnectionPool.get(ConnectionPool.java:382)

    at jsp_servlet.__gencookie._jspService(__gencookie.java:193)

    at weblogic.servlet.jsp.JspBase.service(JspBase.java:35)

    at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:227)

Solution: You can check if weblogic.policy  has the patch jars added, if not below steps would help set it up.

   1. Shut down the Admin Server.


   2. Modify file: $/wlserver_10.3/server/lib/weblogic.policy

//

// For standard extensions directories

//

grant codeBase "file:/<absolute_path_to_patch_dir>/patch_jars/-" {

permission java.security.AllPermission;

};

 3. Restart the Admin Server. 

Comments:

Post a Comment:
  • HTML Syntax: NOT allowed
About

This blog is our place to ramble about technical topics that we (and hopefully you) think are interesting while installing Oracle Retail Products.

Search

Categories
Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today