水曜日 8 26, 2009

最新の OpenSSO ビルドを使用する際の注意事項〜JDK1.6 以上を使うべし



先日、最新の OpenSSO のナイトリービルドの評価のために、
Glassfish に配備して、試しにポリシーエージェント3.0 をインストールしようと
したのですが、以下のようなエラーに遭遇してしまいました。

Enter the path to a file that contains the password to be used for identifying
the Agent.
[ ? : Help, < : Back, ! : Exit ]
Enter the path to the password file: /etc/agentpass.txt

WARNING:
Unreachable Server URL :
http://my.test.domain.com:8080/opensso/identity/authenticate ,
OpenSSO server version may be lower than 8.0. Agent profile/user can not be
validated

どうやら、アイデンティティーサービスが正しく機能してない様子。
エージェントのログファイルには、以下のようなエラーが出てました。


server.log:java.lang.UnsupportedClassVersionError: PWC1651: Class com.sun.identity.idsvcs.IdentityServicesImpl has unsupported major or minor version numbers, which are greater than those found in the Java Runtime Environment version 1.5.0_15

んー、おかしいな??と色々調べてみたところ、
最新の(少なくとも、2009年6月中旬以降) OpenSSO は、
JDK1.6 とともに使用しないといけないみたいですね。

上記の環境では、Glassfish を JDK1.5_0_15 を使って動かしていたために、
不具合が起こっていたようです。
早速、最新の JDK1.6_16 をとってきて、
Glassfish の asenv.conf ファイルを


AS_JAVA="/usr/jdk/jdk1.6.0_16"

と置き換えて、Glassfish を再起動したところ、
ポリシーエージェントのインストールは正常に完了しました。

この注意事項は、OpenSSO ビルド8 のリリースノートに記載される予定です。

About

hanaki

Search

Archives
« 4月 2014
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
今日