X

Geertjan's Blog

  • August 16, 2007

Wicket Tag Navigator

Geertjan Wielenga
Product Manager
The Wicket suite for NetBeans IDE 6.0, discussed yesterday, contains (the start of) a Wicket tag navigator, as shown below:

Right now, nothing happens when you click a tag in the navigator. However, ultimately, the related HTML document will open and the cursor will land on the selected Wicket tag. From there, you can hold down the Ctrl key, move the mouse over the tag in the editor, and then the tag becomes a hyperlink, which you can click to open the corresponding Java document.

Join the discussion

Comments ( 12 )
  • Martijn Dashorst Friday, August 17, 2007

    Does this work correctly when two tags have the same name, but are nested?

    For example:

    <a href="#" wicket:id="foo"><span wicket:id="foo"></span></a>

    add(new Link("foo"){public void onClick() {}}.add(new Label("foo", "Foo"));


  • Geertjan Friday, August 17, 2007

    Click here for the answer, Martijn: http://blogs.sun.com/geertjan/resource/nested-tags.png


  • Martijn Dashorst Tuesday, August 28, 2007

    Nice... keep up the good work!


  • dabar Thursday, September 6, 2007

    Please Geertjan where can I download this module or a demo to test with my NB6


  • Geertjan Thursday, September 6, 2007
  • dabar Saturday, September 8, 2007

    Plugin WicketSupport cannot match its dependencies:

    module javax.jmi.reflect/1 > 1.7.1 module org.netbeans.api.mdr/1 > 1.4.1 module org.netbeans.jmi.javamodel/2 > 1.21.1 module org.netbeans.modules.editor.hints/1 = 1 module org.netbeans.modules.java/1 > 1.25.1.2.2.2 module org.netbeans.modules.javacore/1 > 1.18.1.2.2 module org.netbeans.modules.jmiutils/1 = 2 module org.netbeans.modules.refactoring/1 = 3

    my current NB6 build is NetBeans IDE Dev (Build 200709070000)


  • Geertjan Saturday, September 8, 2007

    For 6.0, I think you need to check out a branch, not the trunk.


  • Geertjan Saturday, September 8, 2007
  • tyrone Thursday, November 1, 2007

    After i build the wicketsupport in the NetBeans 6.0 beta 2, i got the org-netbeans-modules-web-wicket.nbm file. so i want to install this moudle on my platform occured the following error:

    Missing required modules for Plugin WicketSupport:

    module org.netbeans.jmi.javamodel/2 > 1.21.1

    can you give me solution? thanks lot.


  • Geertjan Thursday, November 1, 2007
  • tyrone Sunday, November 4, 2007

    thanks Geertjan, i got it.


  • selvarani Thursday, October 15, 2009

    Gud Eve sir, how r u?

    I have a wicket 1.3.3 support nbm file and i try to add in netbeans 6.1 but i get some error msgs which i pasted below. plz guide me sir. I have gone thru ur blog but i got only wicket 1.4 support nbms. but i am developing application using wicket 1.3.3. U said in ur blog that netbeans 6.7 only supports the wicket 1.4 nbm. help me sir.thank u.

    ------------------------

    Plugin WicketSupport cannot match its dependencies:

    module javax.jmi.reflect/1 > 1.7.1 module org.netbeans.api.mdr/1 > 1.4.1 module org.netbeans.jmi.javamodel/2 > 1.21.1 module org.netbeans.modules.editor.hints/1 = 1 module org.netbeans.modules.java/1 > 1.25.1.2.2.2 module org.netbeans.modules.javacore/1 > 1.18.1.2.2 module org.netbeans.modules.jmiutils/1 = 2 module org.netbeans.modules.refactoring/1 = 3

    --------------------------


Please enter your name.Please provide a valid email address.Please enter a comment.CAPTCHA challenge response provided was incorrect. Please try again.