X

Geertjan's Blog

  • September 10, 2012

Wicket 1.6.0 in NetBeans IDE 7.2

Geertjan Wielenga
Product Manager

Get it here:

http://plugins.netbeans.org/plugin/3586

Then use the Web Application wizard to select your new Wicket 1.6.0 library:

The result:

For Maven developers, after adding support provided by the NetBeans/Wicket plugin:

Join the discussion

Comments ( 12 )
  • guest Friday, September 14, 2012

    Hey Geertjan,

    Unfortunately no Wicket 1.6 exists. Wicket 6.0.0 is the version you want.


  • Geertjan Friday, September 14, 2012

    You can see quite clearly from the screenshots that Wicket 6 is in the name of the JARs. So Wicket 6 is being used.


  • ReinoutS Friday, September 21, 2012

    It appears that your plugin repository at https://blogs.oracle.com/geertjan/resource/NetBeans4Wicket.xml hasn't been updated yet?


  • Geertjan Friday, September 21, 2012

    It appears that you didn't read the first sentence of this blog entry where you're told where to find the plugin?


  • ReinoutS Tuesday, October 9, 2012

    I didn't say I couldn't find it. I was trying to be helpful by reminding you that your plugin repository wasn't up to date so that users of an old plugin version wouldn't be notified of an upgrade. You're welcome!


  • Geertjan Tuesday, October 9, 2012

    OK, thanks! Hope you're enjoying Wicket with NetBeans!


  • guest Wednesday, November 14, 2012

    Thanks for the Plug-in. Any sites/ blogs regarding persistence stratergies while using wicket


  • Meziane Tuesday, November 5, 2013

    Hi Geertjan,

    I am unfortunately having trouble to bring this simple project to run.

    I am using Netbeans 7.4 and Glassfish 4.

    I don't see the javaee-inject-1.4.x.jar in your libraries-list.

    Without this jar (javaee-inject), I get the error "can't find symbol class: getComponentInstantiationListeners().add(new JavaEEComponentInjector(this)).

    After adding this jar, I get "incompatible types: JavaEEComponentInjector cannot be converted to IComponentInstantiationListener".

    I tried the wicket-1.5.3 version, but without success.

    Is this really working for you?

    Meziane


  • Geertjan Tuesday, November 5, 2013

    The plugin hasn't been updated to NetBeans IDE 7.4 yet, will be done in the coming weeks.


  • Meziane Tuesday, November 5, 2013

    Hi Geertjan,

    ouf! I succeed at last to get it running!

    For potential interested: I used the netbeans plugin (wicket 1.5.3), I added manually the jars from jeff's blog (cglib-nodep-2.1._3.jar, javaee-inject-1.4.10.jar, wicket-icoc-1.4.10.jar)

    I noticed that wicket-icoc-1.5.3.jar doesn't contain a ComponentInjector claas, but wicket-icoc-1.4.10.jar does:

    public class ComponentInjector implements org.apache.wicket.application.IComponentInstantiationListener

    I don't understand, why this is not documented in wicket doc or else where: this make our life more difficult as it is.

    I spend 80% or more of my time looking after jars to use.

    It's a really a pity!

    Meziane

    PS: Could you please confirm, that you get it running with the jars you indicated??


  • Meziane Wednesday, November 6, 2013

    Hi Geertjan,

    ouf! I succeed at last to get it running!

    For potential interested: I used the netbeans plugin (wicket 1.5.3), I added manually the jars from jeff's blog (cglib-nodep-2.1._3.jar, javaee-inject-1.4.10.jar, wicket-icoc-1.4.10.jar)

    I noticed that wicket-icoc-1.5.3.jar doesn't contain a ComponentInjector claas, but wicket-icoc-1.4.10.jar does:

    public class ComponentInjector implements org.apache.wicket.application.IComponentInstantiationListener

    I don't understand, why this is not documented in wicket doc or else where: this make our life more difficult as it is.

    I spend 80% or more of my time looking after jars to use.

    It's a really a pity!

    Meziane

    PS: Could you please confirm, that you get it running with the jars you indicated??


  • Florin Pruna Saturday, November 16, 2013

    NetBeans 7.3

    wickey 1.6

    getComponentInstantiationListeners().add(new JavaEEComponentInjector(this)).

    I get incompatible types:

    required:IComponentInstantiationListener

    found:JavaEEComponentInjector


Please enter your name.Please provide a valid email address.Please enter a comment.CAPTCHA challenge response provided was incorrect. Please try again.