X

Geertjan's Blog

  • May 14, 2013

Corona SDK Lua IDE on the NetBeans Platform

Geertjan Wielenga
Product Manager

The Corona SDK lets you build rich mobile apps for iOS, Android, Kindle, and Nook. The Corona SDK uses Lua as its programming language. Lua Glider has been created by M.Y. Developers LLC on the NetBeans Platform and NetBeans IDE as an advanced IDE for Corona SDK professionals and beginners alike. Lua Glider's latest release is 1.9, released 11 May 2013.

Its many features include an advanced debugger, variables explorer, call stack, adaptive auto-complete, built in documentation, real-time breakpoints, split screen support, asset preview, simulator remote, theme switcher, and much more.

YouTube has several videos on Lua Glider (previously known as Corona Cider), including this very inspiring introduction:

Further info:

http://www.coronalabs.com/products/corona-sdk/

http://www.mydevelopersgames.com/Glider/

http://forums.coronalabs.com/topic/34829-lua-glider-v-19-launch-discount-code-included/

http://www.holamariquita.com/?p=136

http://www.raywenderlich.com/22064/how-to-make-a-simple-game-with-corona

Join the discussion

Comments ( 3 )
  • Mohamed Thursday, May 16, 2013

    Does this mean that you can include LUA in the free NetBeans and use it instead of Lua Glider? Would that be possible?


  • Geertjan Thursday, May 16, 2013

    Possibly, but Lua Glider itself isn't free.


  • guest Monday, July 6, 2015

    I installed this and it expired and it broke my netbeans. Just wondering, because it would be awesome, if you guys could just add Lua support to netbeans in the same manner that you support php, html, javafx, so that not only could netbeans support Lua projects, but also involve Lua scripting in other projects with other main languages. Such as Java or C/C++. That would be gangbusters. seriously. I don't like the fact that this is in the plugin repo and suddenly expires because I didn't pay for it. Not the fact that it is a payware plugin, thats fine. It did not warn me, and if it did, not well enough. I mean, give me big Dollar/Euro/Pound sign saying "I COST MONEY". Uninstalling it after an upgrade to my NetBeans meant manually deleting files all over my hard drive. That also was a terrible ordeal that no end-user should ever experience. So fie on the Glider I say. Bring first class support for free to netbeans please, if only to prevent others from the same fate. Otherwise i'm stuck with VI.


Please enter your name.Please provide a valid email address.Please enter a comment.CAPTCHA challenge response provided was incorrect. Please try again.