Monday Sep 17, 2007

bge support for BCM5755M ethernet adapter

CR 6589496 was filed to add support for the BCM5755M ethernet adapter to the Solaris bge driver but since there's no suggested fix yet, I thought I'd experiment with the source to see if I could hack the driver myself so that it'd drive the chip.  Somewhat surprisingly (since I don't have specs for this device), my modified bge works well.  I had to configure networking on the system before it began resolving domain names, but in the end, it's up and I even downloaded the latest Nevada dvd image using this interface. 

If you're interested in the changes I made, here's the patch.  To use with your system, do the following:

  1. Patch the bge source and rebuild.  See the OpenSolaris Developer's Reference Guide if you need details.
  2. In a shell, type "mv /kernel/drv/bge /kernel/drv/bge.orig" (or "mv /kernel/drv/amd64/bge /kernel/drv/amd64/bge.orig" if you have a x64 system) to back up the original and move the binary you built to where the original was.  I replaced both on my system just to be safe.
  3. Enter the line "bge "pci14e4,1673"" into the /etc/driver_aliases file.  This allows the system to recognize the PCI ID of the network adapter and associate the driver module with it.
  4. In a shell, type "touch /reconfigure".  This will cause the system to rescan its hardware.
  5. Reboot.
  6. You can verify that your version of bge is running by entering "modinfo | grep bge" in a shell and checking that the version number has been bumped.

Tuesday Sep 11, 2007

Dell Latitude D830 added to Solaris HCL

My submission to the Solaris Express Hardware Compatibility List was published in BigAdmin, so there is now another laptop for people to choose from to run Solaris on.

Wednesday Sep 05, 2007

More D830 HW support in Solaris

Looks like CR 6580728 "Upgrade Xorg Intel video driver to xf86-video-intel-2.1.0" has brought support for the full resolution of my display on the D830. I should try it ;)

I also received word from Simon-Bernard Drolet that the latest release of the OSS (v4.0-1006) produces sound from the line-out jack, though not from the speakers.  We are discussing this issue in the 4front forums.

About

I'm a Software Engineer at Sun Microsystems, and an alumnus of the University of Texas at Austin - Hook 'Em Horns!

Search

Categories
Archives
« September 2007
SunMonTueWedThuFriSat
      
1
2
3
4
7
8
9
10
12
13
14
15
18
19
20
21
22
23
24
25
26
27
28
29
30
      
Today