Tuesday Oct 19, 2010

JAXB Compile Failure

When compile my code that uses JAXB with JDK1.5, I got an error "cannot access javax.xml.stream.XMLEventReader". There is no such error if I compile it with JDK1.6. The way to fix it is to include jsr173_api.jar in the classpath along with jaxb-api.jar, jaxb-impl.jar and jaxb1-impl.jar. This class javax.xml.stream.XMLEventReader is part of JDk1.6, that is why the compiling issue only happens to JDK1.5.

About

gc

Search

Categories
Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today