ATI Radeon support for compiz easy install

Do not use these packages anymore, instead install the latest version of OpenSolaris or nevada everything in integrated now.

Thanks to the ATI radeon DRI 3D driver Minskey is porting to Solaris. Compiz is running on ATI radeon based machines.

The latest binaries release of this driver can be found here.

To check if compiz is likely to run on your machine you can either download my updated hardware check script or
run the following command line in a terminal :

# /usr/sfw/bin/wget -O - http://www.gnome.org/~erwannc/compiz/compiz-0.6.2-on-solaris-check.perl | /usr/bin/perl

If the result is positive then :
- download the updated installer.
- and run it with the --with-experimental-ati-support argument.

# ./compiz-0.6.2-for-solaris.sh --with-experimental-ati-support

Note : this driver is not fully stable so you might experience Xserver crashes while using compiz. Use at you own risk !

Feedback is more than welcome as I don't physically have access to an ATI radeon based machine.

Many thanks to Darren Kenny for the ATI Xorg configuration.

Comments:

Unfortunately, Minskey's ATI driver doesn't work on R500 and newer ATI graphics devices.

On my Ferrari5000, I must use the RadeonHD driver
(http://wiki.x.org/wiki/radeonhd) which doesn't support
2D or 3D acceleration yet :-(

Posted by Renaud on January 25, 2008 at 09:40 AM CET #

Does the driver also provide xrandr support, that which allows me to dynamically reconfigure device settings; for example dynamically adding another display?

Posted by Stacey Marshall on January 28, 2008 at 05:45 AM CET #

Hi Stace,

Testing on my Ferrari 3400, randr does indeed now work, even via the desktop menu item =O)

The only thing I found missing in the above instructions is the need to run "bootadm update_archive" after the driver install. This is implicit if you reboot with "init 6", but I prefer a quicker bounce, and don't...

Everything else is quick and easy.

Ta,
Mark.

Posted by Mark R. Bowyer on January 28, 2008 at 08:05 AM CET #

Thanks for the check script. When run on a Radeon Xpress 200M, the script says the following.
=-=-=-=-=-= Video Card checks =-=-=-=-=-=
supported card type : none
no supported card detected. Compiz not likely to work on this system
Thanks again. Kept me from having to poke through myself.

--LSA

Posted by list.serv.address on January 29, 2008 at 11:12 PM CET #

In case of opensolaris upgrade, think to remove the ATI driver and reinstall it after upgrade.

I lost my console after an upgrade from b77 to SXDE 01/08
My latop is a Sony with ATI 9000 3D.

Posted by Gilles on February 08, 2008 at 03:21 AM CET #

Post a Comment:
Comments are closed for this entry.
About

user13342361

Search

Categories
Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today