UCM Search Cache Turned Off in UCM PS3 (11.1.1.4.0)

I just recently found this problem at a customer. There is a bug in the PS3 (11.1.1.4.0) release of UCM that leaves the search cache turned off by default.

I had the searchcache and searchquery trace sections enabled to examine the queries coming to UCM and saw there were no searchcache statements in the trace output. I set UseSearchCache=true in config.cfg and viola the search cache was turned on.

I have confirmed with Oracle Support that this is known bug. I have not seen any patches available for PS3 yet. For now just make sure that for any PS3 installs you set UseSearchCache=true in config.cfg to make sure the search cache is turned on.

In my case this was a fresh install of PS3. I would also expect, although I have not tested it, that this would also occur on instances that were upgraded to PS3 from an earlier release. So, just set UseSearchCache=true to be safe.

Comments:

The indexer must not be running. After you make any changes to content (add, delete, update) the indexer must run to update the search index. Check the repository manager to make sure the indexer is running.

Posted by guest on March 07, 2012 at 04:03 AM CST #

indexer is not running and its state is aborted.

Posted by Imran Ali on March 07, 2012 at 04:15 AM CST #

indexer is not running and its state is aborted.

Posted by Imran Ali on March 07, 2012 at 04:16 AM CST #

Post a Comment:
  • HTML Syntax: NOT allowed
About

Kevin Smith is a Technical Director in Oracle Consulting's WebCenter practice. He has been working with content management products since 2004 when he joined Stellent.

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today