OpenSolaris 2009.06 Bug with vncviewer, and a workaround

I had been running OpenSolaris 2008.11 on one of my machines for a long time, and when I recently upgraded it to the June 2009 (2009.06) release, all of a sudden the remote desktop control feature stopped working.  I mean, I could type "vncviewer " and would see the desktop initially, but it just didn't refresh its display.

Turns out I'm not the only one who ran into this problem, which doesn't seem to be fixed but at least it has a workaround.  The workaround is to turn off visual effects for desktop actions.  To do that, go to the System menu, choose "Preferences -> Appearance" and you will see a panel that looks like the image below.  Be sure to check "None:" for the visual effects, and vncviewer from other computers (including Macs, which is where I first saw the problem) should go away.

Here's a link to the discussion I found about this problem.

And here's what the preferences panel looks like in OpenSolaris 2009.06 and later builds:





Powered by ScribeFire.

Comments:

thanks for your sharing!

Posted by supra shoes on December 06, 2009 at 03:58 PM PST #

Thanks for sharing the useful information with me.

Posted by True Religion jeans on December 06, 2009 at 04:03 PM PST #

Post a Comment:
Comments are closed for this entry.
About

The views expressed on this blog are my own and do not necessarily reflect the views of Oracle. What more do you need to know, really?

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today