WebSphere Hypervisor Edition and VirtualBox

Finally I got some time to check on the WebSphere Application Server Hypervisor Edition which according to the IBM Web-Site is optimized to run on Cloudburst appliances. I don't have appliance h/w access and I needed to check on how its packaged. Here is what I found in my first walk-through, more details will be added if I found them.
Packaging:
The software is packaged and available in several forms:
1. Appliance Image which is OVA formatted virtual image and intended to be used with Cloudburst appliance
2. ESX images to be used with VMWare ESX Servers
3. OVF formatted virtual machine image, which can be used on any virtualization platform where OVF is supported

The OVF image download file is composed of several files which will appear as different disk in VirtualBox and they hold different software and profiled such as WebSphere App Server, IHS and so on...
So I picked up the OVF image and decided to run it on the VirtualBox on my OpenSolaris box. As VirtualBox supports the OVF format and it can be imported using just few mouse clicks.
When I did that this is what I found:
The OS form some reason, mostly due to absence of Novell SUSE in my VirtualBox install appears as Ubuntu. So I continued with that and booted it. Everything went fine except I ran into a display issues as my VirtualBox did not like the display drivers that is part of the image currently available. More on that in next blog for the moment I just wanted to check how the install/startup and service configuration goes so I continued with a command line console access. After going through the license acceptance and select the right profile everything came back up as expected and I had a running instance of WebSphere Application Server with two profiles running in my VirtualBox. One of the profiles is for the "nodeagent" while other is regular "Application Server Profile".
This is what you need to try this:

  1. Obtain/install a copy of VirtualBox
  2. Download the HyperVisor Edition image in OVF format
  3. Import the OVF file
This should get you going. Later I decided to change it to OpenSuse option in VirtualBox and did not find any difference in behaviour so I assume its OK with either option.


Comments:

Your experience is very interesting. I'd love to hear more about your progress.

Posted by RonenL on January 19, 2010 at 04:18 AM PST #

vmx files are recoginzed by virtualbox.
Can you please throw ideas to load WebSphere_ESX.vmx, WebSphere_ESX_full.vmx files onto virtualbox?

Thanks

Posted by bhaskar on February 03, 2010 at 10:17 PM PST #

@dkumar
i have the issue as well.
As the websphere hypervisor edition is only vmware supported, you only have driver for ...vmware graphic card.
I will try to mount a vmdk on an other vm, add virtualbox graphic card driver in the right lib folder, reconfigure Xorg.
i will keep you informed

Posted by sebussalsa on December 06, 2010 at 02:02 PM PST #

Post a Comment:
Comments are closed for this entry.
About

dkumar

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today