"initialization error: class file has wrong version" message in JDeveloper 10.1.2.x

The "initialization error: class file has wrong version" has become a somewhat recurrent error message thrown by JDeveloper 10.1.2.x as newer JDKs have been released in the last years. Note that JDeveloper 10.1.2 was developed to run with JDK 1.4.2.

The reasons for this error message to be thrown include:

  • A JDK version higher than 1.4.2 is being used and some unexpected incompatibility conflicts can occur because of that

  • Some of the libraries used on the workspace and/or project were compiled with a newer JDK version

So, it is strongly recommended to use newer JDeveloper versions (10.1.3 - 11g) for newer JDKs.


JDeveloper 10.1.2 will be desupported in December 2010 (or later depending on the support contract). Further information about this can be seen at http://www.oracle.com/support/library/brochure/lifetime-support-middleware.pdf


Comments:

Post a Comment:
  • HTML Syntax: NOT allowed
About


Principal Technical Support Engineer in the Exalogic Enterprise Support Team (EEST).

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today