Friday Apr 29, 2005

Sub-diversion

My last update indicated that Subversion 1.2.0-rc2 packages might be released this week. After a bit of testing on one of my sandbox machines, it appears that a long standing bug somewhere in the system is still causing me headaches. Back in the Subversion 1.0 timeframe, when I started building Subversion for testing purposes, I'd get a message indicating that character translations for messages could not be found. The messages were usually of the form "Cannot create converter from native to UTF-8" or vice versa. This would affect commits to the repository, but not checkouts or other non-write operations. I managed to put together a patch that would cause the messages to go away with no apparent ill effects, but the fix makes me uneasy -- it requires me to override the macro APR_LOCALE_CHARSET a couple of times in the libsvn_subr module utf.c. My patch sets this value to the string "ASCII" instead, which appears to do the trick, at least in my locale.

The patch does not apply to svn 1.2.0-rc?, so now I need to go and find out if the problem is really with Subversion, or with APR (0.9.6). I am not able to find much on the subject by searching mailing lists, or googling for the relevant error terms. It appears that the issue is only present on Solaris, and there aren't that many Subversion users out there running on Solaris just yet. If anyone has ideas why I would be seeing this behavior, please drop me a line!

About

comand

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today