How to compile EventMachine on Solaris

thinやneverblockを使う際に必要になるeventmachine。しかしSolarisではデフォルトでは、gem install eventmachineではコンパイルエラーでインストールできません。eventmachineをインストールするには、一工夫必要です。

まずgccではなくSun Studioをインストール。

その後、環境変数に以下の値を設定します。


export CXX=g++



(/usr/sfw/binにはパスを通しておいてください)

そして


gem install eventmachine



これでthinもneverblockも使うことができます。

投稿されたコメント:

OpenSolaris/Nevada の最近の版であれば、g++が入っています。
環境変数CPP を export CPP=g++ とすれば、うまくいきます。g++ は/usr/sfw/bin/g++ です。pathを通せばオッケーです。

Posted by shita on 10月月 25日, 2008年 at 05:36 午後 JST #

コメント
  • HTML文法 不許可
About

Tomo

Search

Archives
« 4月 2014
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
今日