Acer wireless problem solved!

I posted an entry yesterday about wireless problems with my new Acer TravelMate. They seem to be solved now, so here's what I did for the benefit of fellow Googlers. The Acer TravelMate 4020 has an Intel 2200BG wireless card that can run at various speeds, up to 54Mbps. I have a DLink DSL G604T wireless ADSL router that can support 802.11b 11Mb and 802.11g connections of 54Mbps. Browsing worked fine from the Acer, but VoIP and streaming music did not. I noticed that the two other laptops in the flat were running at 11Mbps and were having no problem placing Internet calls or streaming music to the Apple AirPort express. I downloaded the latest driver for the 2200BG from Intel, which comes with a management tool. Using the management tool I set the card to work at 802.11b only and music now streams without any jerking to the AirPort Express. I'll test it evening, but I suspect the VoIP app will now also work fine. There's no need for 802.11g as the ADSL speed is 1Mb and the other two machines I might need to access are 802.11b only. I wonder where the problem was occurring - at the router or on the laptop? At any rate, it's fixed now. The next thing is to work out if I can be logged into Sun's vpn and streaming music to the local AirPort at the same time...
Comments:

Just wanted to say thanks for this post, it helped me resolve my problem with my Acer 1690 and the intermittent wireless connection. Rather than dowloading the management tool I used The Wireless Connection Properties, Configure and was able to set Wireless to 802.11b only and its worked a treat.

Posted by Paul K on May 27, 2006 at 05:19 PM GST #

Thanks for your comment :) I get people coming across my blog literally every day after googling for 'acer wireless problem' - seems like the issues we've faced may be widespread.

Posted by Chris on May 28, 2006 at 04:50 AM GST #

You're not wrong there buddy. I too have an Aspire 1690 and I'm dropping connection every minute or three, and come to your forum via a google search to remedy it.

Posted by Mat Brett on May 28, 2006 at 04:50 PM GST #

Can anyone tell me the exact steps Paul used to edit that setting? I cannot seem to find it on my Acer and I have the same issue as the others have.

Posted by Joe on July 17, 2006 at 10:24 PM GST #

Hi. My Acer Ferrari 3400 (305002 model)'s inbuilt wireless connection does not appear to be working. It cannot detect any wireless networks despite there definately being dozens in area (including my own wireless router, all of which works with other Dell wireless notebook). I have tried disabling wep hoping it would then see the network but cant. Wired LAN works fine. The system says the adaptor is fine and I have tried disabling it and enabling it, the driver is up to date. I downloaded the WLAN 802.11g driver from Acer website and installed it and it still does not work though there is now a new WLAN 801.11g mini-PCI Module Configuration Utility to use. When I try to “Enable Radio”, I get a message “The radio on your 802.11 network adapter is still disabled. Use the hardware radio control switch to enable it” What and how do I do that? Please help as this problem has caused us a lot of trouble. Thank you. Direct replies to cersei69@hotmail.com welcomed

Posted by Thomas on January 22, 2007 at 11:00 PM GST #

I have an Aspire acer 9410 and it's impossible to connect with a wireless network although other laptops in the same place can.what I have to do?

Posted by frida on February 05, 2007 at 01:53 PM GST #

had same problem with an Acer 5512 after it returned from its 3rd repair (a screen fix and 2 motherboard replacements) - the wireless was dropping about 4% of packets and slowing to 2000ms pings to/from the router. Switched it to "b" and it pings at a steady 2ms - thanks for the tip!

Posted by redfoot on February 11, 2007 at 06:13 PM GST #

Hi
I have a Acer travelmate 8210
I cant connect either to my office network or my home network, i put all the settings(home and office), it simple won´t connect, it doesnt even start to connect, just shows the x in system tray even if the wireless card is turned ON... i connect with all my other laptops with same settings...
ive tryed installing a new driver from intel, going back to the acer driver, to see if it works.
LAN works fine...
PLEASE HELP

Posted by Nelson Diogo da Silva on November 27, 2007 at 05:23 AM GST #

Ok, ive removed the most updated drivers for the 3945 card from intel...
and installed the one´s from Acer website
ive tryed this before and it didnt work
now it works, i hope it works forever
i can connect to my homenetwork and office network :P

Posted by Nelson Diogo da Silva on November 28, 2007 at 04:03 AM GST #

Thanks for comments. My wireless was switching off and on all the time and i went under Wireless Connection Properties, Configure, Advanced and set everything to 802.11b only and now it works perfectly!!

Posted by Marchello on November 29, 2007 at 07:45 PM GST #

My Travelmate 5720 was constantly dropping it's wireless connection too and Ive just read above and switched to 802.11b only and it's all fixed. I had been trying for a month to fix this. Acer wanted me to send it to them for an engineer to look at! Thanks guys!

Posted by Davie Quinn on December 31, 2007 at 10:28 AM GST #

Surely setting to b reduces your speed?
Again, I am on a 5720 ;(

Posted by Tim Morley on February 20, 2008 at 02:31 PM GST #

i have an acer 3680 and have the same problems with the wireless. i sent it to acer and it came back the same way. after google searches, on my toshiba, i found a lot of people said to download the driver for xp as i have the crappy vista os. i did this and downloaded it to my acer and have been connected since, although i havent been able to connect to my neighbors unsecure network i can connect to a secure network.....any ideas why i cant hit a hotspot?

Posted by matt miller on March 01, 2008 at 10:09 PM GST #

I'm having the same issues also. I've been messing about with different settings including changing to 802.11b exclusively (there is also a setting that covers 802.11a, b and c) which is the default.

I then changed the power management on the wireless to maximum performance / power. So far so good. I will update if it craps out again.

Posted by Pete on March 11, 2008 at 08:31 PM GST #

Hi,
I have an Acer Aspire 1690 Laptop. The Mbps keeps changing from 54 even down to 1. Repair seems to get it back on track but only for a short while. My other laptop connected wireless to the same router has no problems. Any suggestions? Can I upgrade to a faster Mbps?

Posted by Bob on August 25, 2008 at 02:06 PM GST #

Chris Saul, I LOVE YOU! This post single-handedly saved me from throwing my Acer 1690 into a large body of water... or off a bridge... or more likely sacrificing it to the craigslist free-cyclers. I have had this laptop for almost two years and have fought this problem for that long. I've searched for answers to no avail and having just desperately maxed out the memory slots trying to save my sanity, I found myself on one more last ditch Google search for help... and there it was. THANK YOU for blogging! THANK YOU! THANK YOU! THANK YOU!

Happy Birthday to me!~

Posted by Violet on October 03, 2008 at 04:32 AM GST #

Thanks for this info. Just sorted my 1640 by changing to 802.11b. Cheers!

Posted by Hammerhead on January 22, 2009 at 08:29 AM GST #

Thanks Mate,

Following the wiFi fix you made some time ago. I can now use skype on my Acer Aspire 1650 without continual line-drops and losing my rag!

Paul

Posted by Paul on February 12, 2009 at 01:29 AM GST #

Hi everyone...

just an FYI... My acer aspire laptop quit after a year. I am very frustrated. I have computer experience and I kept this computer very clean. However, it became very slow. I doubled memory, and then the wireless crapped out. I tired your solutions to no avail.

I wont buy another ACER and I don't think you should either.

Posted by jonny on April 05, 2009 at 12:53 AM GST #

Im also not buying any ACER again... i had 3...and all of them resulted in some sort of failure...

i have alienware laptop now and i very happy... not one crash or problem with drivers, since 6 months ago...

Posted by Nelson on April 16, 2009 at 04:48 AM GST #

i had the same problem (Acer X3810), wireless detection of networks is erratic and could find mine own network.... All acer did was ask me to un-install and install driver. Problem is the modem did detect some networks but not mine!! I finally managed to figured out wat to do by seeing what you guys did here. My acer is running on Vista so I went to Device Manager, click on the wireless adapter and select Advanced and tried the diferent values under "Country Region"...and one of them works.. hope this helps anyone who have similar problem

Posted by msfeline on August 19, 2009 at 10:26 AM GST #

I've been trying every site I can find to fix the wireless switch on my Acer Travelmate 290 which just would not activate.

I have tried reloading drivers, activating and deactivating the network connecting, reinstalling againa and again and nothing made a difference until .... finally found a fix that worked for me. Hope it helps.

Go to http://forum.notebookreview.com/showthread.php?t=281138

I used Orezavi's link to upload launchManager from Acer, rebooted, and all was well. Hope this helps.

Yvonne

Posted by YvonneB on October 07, 2009 at 11:45 AM GST #

I've been trying every site I can find to fix the wireless switch on my Acer Travelmate 290 which just would not activate.

I have tried reloading drivers, activating and deactivating the network connecting, reinstalling againa and again and nothing made a difference until .... finally found a fix that worked for me. Hope it helps. http://www.gifico.com

Posted by louis vuitton on November 19, 2009 at 02:16 AM GST #

my laptop is giving me problems that when i am connecting to the wireless internet, it allows me to enter the password and then after it says,
the network password needs to be 40bits or 104bits depending on your network configuration. this can be entered as 5 or 13 ascii characters or 10 or 26 hexadecimal characters.

Posted by munya on January 29, 2010 at 06:00 PM GST #

Thanks, My lappy just died so I just dusted off an old aspire 1690 to use and discovered it had the wireless connectivity issue, Paul K's solution worked a treat. Thanks

Posted by Talste on April 09, 2010 at 10:22 AM GST #

Hi,
I am not at all techy minded but i hope taht some genius on your blog can help me.
I just bought a new Acer Aspire 1420p - which is great but the wireless reception only works if the computer is really close to the router. I phoned Acer but they didnt have a clue. Is there any way I can make the reception stronger? Or is it a duff one? There are 3 other laptops in the house whose reception is fine- any ideas? If you do could you pls make it 'for idiots' ie me
Here's hoping
Heather - UK

Posted by Heather Matuozzo on June 05, 2010 at 11:47 AM GST #

Thanks, My lappy just died so I just dusted off an old aspire 1690 to use and discovered it had the wireless connectivity issue, Paul K's solution worked a treat. Thanks

Posted by parker pen on June 25, 2010 at 04:21 AM GST #

I haven't quite figured out why the sexual urge of men and women differ so much. And I never really figured out the whole Venus and Mars thing. I have never figured out why men think with their head and women with their heart.

Posted by Olivea32 on July 07, 2010 at 05:58 AM GST #

Thank you so much for this! I've been wrestling with the wireless on my Acer Travelmate 4021 for a few years. The problem is with either Windows OS or the Intel drivers. I've been running Linux on this laptop for years without any trouble because the I was plagued with this wireless issue on Windows XP/Vista. Since the wireless works like a champ on Linux, I can only point the finger at Windows OS or Intel windows drivers.

Posted by Tom Black on July 19, 2010 at 09:44 AM GST #

I like playing the world,i always do somethings different,but sometine,I do something like others do.

Posted by colourugg on September 10, 2010 at 03:59 AM GST #

The problem is with either Windows OS or the Intel drivers. I've been running Linux on this laptop for years without any trouble because the I was plagued with this wireless issue on Windows XP/Vista. Since the wireless works like a champ on Linux, I can only point the finger at Windows OS or Intel windows drivers.

Posted by Tiffany jewelry on October 24, 2010 at 11:31 PM GST #

Thanks, My lappy just died so I just dusted off an old aspire 1690 to use and discovered it had the wireless connectivity issue, Paul K's solution worked a treat.

Posted by discount Tiffany jewelry on October 24, 2010 at 11:32 PM GST #

Post a Comment:
Comments are closed for this entry.
About

christophersaul

Search

Archives
« April 2014
MonTueWedThuFriSatSun
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
    
       
Today