Upgrade to build 83 fails.

On upgrading the home server to nv83 the system would not make it to milestone multi-user. Instead it would fail and eventually time out leaving a number of critical services not running. Specifially dhcp and the graphical login rendering all the Sun Rays and also the console pretty much useless. After a short amount of digging I tried to revert to build 82 but the luactivate command hung running “matastat -i” which was stuck here:

1687:   /usr/sbin/metastat -i
 fef04647 pollsys  (806df78, 1, 8046608, 0)
 feeb5ea2 poll     (806df78, 1, 5265c00) + 52
 fed13c43 read_vc  (806f258, 8082038, 2328) + 117
 fed2b7b8 fill_input_buf (806fe18, 0) + 44
 fed2b864 get_input_bytes (806fe18, 80466d4, 4, 0) + 88
 fed2b8d7 set_input_fragment (806fe18) + 33
 fed2b26b xdrrec_getbytes (806f2a0, 804672c, 4) + 7b
 fed2b109 xdrrec_getint32 (806f2a0, 804674c) + 69
 fed2b1b1 xdrrec_getlong (806f2a0, 80467d0) + 15
 fed2a188 xdr_u_int (806f2a0, 80467d0) + 30
 fed1a31d xdr_replymsg (806f2a0, 80467d0) + 3b9
 fed1317c clnt_vc_call (80671a8, 6, fee11010, 8046880, fee11064, 804688c) + 238
 fee10096 mdrpc_getset_2 (8046880, 804688c, 80671a8) + 3e
 fedb5819 clnt_getset (fee42e89, 0, 9, 8046980, 80469c0) + d1
 feddc7c9 getsetbynum (9, 80469c0) + 39
 fedcb007 metasetnosetname (9, 80469c0) + 43
 fedf6549 meta_smf_getmask (8047490, 80472bc, feffb7cc, 0, 0, 0) + 159
 080534ec main     (2, 8047300, 804730c) + 3a8
 08052ce6 _start   (2, 80474f8, 804750b, 0, 804750e, 8047537) + 7a

Scanning http://bugs.opensolaris.org this looks like 6656879 so I'm back on build 82 and will be watching that bug carefully. Once again I'm thankful for live upgrade making the return trip to build 82 just a case of rebooting.

In other news I had reason to be thankful for the hourly snapshots that the server takes allowing me to recover the “.mozilla” directory for one of the users after they pressed the wrong button when asked the question about firefox not having exited cleanly.

Comments:

You've been heard : "State 8-Fix Available"

Posted by guest on February 21, 2008 at 07:48 AM GMT #

Indeed there is even a workaround in the bug report. Just need to schedule some downtime. It really has come to something when you have to schedule down time on your home computer.....

Posted by Chris Gerhard on February 21, 2008 at 07:51 AM GMT #

Post a Comment:
Comments are closed for this entry.
About

This is the old blog of Chris Gerhard. It has mostly moved to http://chrisgerhard.wordpress.com

Search

Archives
« April 2014
MonTueWedThuFriSatSun
 
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
    
       
Today