X
  • ADF
    January 3, 2013

The slow JDeveloper startup mystery

Guest Author

I am currently producing my first ADF Insider session. It contains a few recorded demonstrations, which I did using an Oracle Enterprise Linux 6.3 virtual machine. I was pleased by the performance and polish of the OS, and recording was a breeze. If only JDeveloper hadn't been so slow to start...

Now, some of you will probably tell me this is business as usual. This is unfair. Since the first 11g release in 2007, JDeveloper's performance has improved steadily. Bex Huff also gave very effective advice on his blog on how to tune your JVM options to improve the tool's speed. And the improvements brought in the 11.1.2 branch show we can expect even more performance for 12c.

What I saw in my VM was beyond what I had seen before, anyway. The splash screen was being displayed for nearly a minute before the progress bar showed... And no update centers were available when I checked for updates, preventing me from downloading any. Clearly, something was amiss. With 8gb allocated to it and two virtual CPU cores, resources weren't the problem. After searching on the web for a few minutes and coming back empty-handed, I decided to start JDeveloper on the command line. This is what I got:

Out of curiosity, I looked at my /etc/hosts file. For one reason or another, the actual host name (OracleLinux6) wasn't specified for 127.0.0.1 (IPV4) and ::1 (IPV6). Simply adding it to the file did the trick. JDeveloper was itself again afterwards.

You see? You shouldn't blame JDeveloper for everything... ;-)

Be the first to comment

Comments ( 0 )
Please enter your name.Please provide a valid email address.Please enter a comment.CAPTCHA challenge response provided was incorrect. Please try again.