How to enable Aero in Vista ?

If you have a Windows Vista Capable PC and would like to experience Windows Aero (translucent windows, windows flip, windows flip 3d and smooth window performance) on Vista Ultimate, then:

  • Go to Control Panel
  • Select Personalization
  • Select Window Color and Appearance
  • Choose Windows Aero in Color scheme.

Read more about the 4 tiers of user interface in Vista.

If you have Vista Premium Ready PC and you install Vista, then Aero will be automatically configured on your machine. Here are the requirements for such a configuration:

  • a 1 GHz 32-bit (x86) or 64-bit (x64) processor
  • 1 gigabyte of system memory
  • a DirectX 9 compatible graphics processor, with a Windows Display Driver Model (WDDM) driver, and a minimum of 64 MB of Video RAM
  • 40 GB hard drive with 15 GB free space
  • DVD-ROM Drive
  • audio output and Internet access

Technorati: aero glass vista

Comments:

Well I have a Sony VAIO VGN-BX561B Notebook, and it is a Vista Capable PC, but I can't find the Windows Aero option in the Control Panel. Any ideas? System Information: --- Motherboard: VGN-BX561B Basic I/O System(BIOS): Ver 1.00PARTTBLx Central Processing Unit(CPU): Intel(R) Pentium(R) M processor 1.73GHz Physical Memory: 512MB Hard Disk X 3 TOSHIBA MK4032GSX ATA Device (37GB) Video Card X 2 Mobile Intel(R) 915GM/GMS/910GML Express Chipset Family (Microsoft Corporation - XDDM) Mobile Intel(R) 915GM/GMS/910GML Express Chipset Family (Microsoft Corporation - XDDM) Monitor X 2 Generic PnP Monitor Generic PnP Monitor Audio Device: Realtek High Definition Audio Network Adapter Local Area Connection - Marvell Yukon 88E8053 PCI-E Gigabit Ethernet Controller (Media disconnected) Wireless Network Connection - Intel(R) PRO/Wireless 2200BG Network Connection (Connected) Modem: HDAUDIO SoftV92 Data Fax Modem with SmartCP Keyboard: Standard 101/102-Key or Microsoft Natural PS/2 Keyboard Mouse: Alps Pointing-device for VAIO

Posted by Charbel Saad on May 02, 2007 at 05:58 AM PDT #

I updated the entry, one step was missing. Control Panel -> Personalization -> Window Color & Appearance -> Windows Aero. Can you look at it and see if it works this time ?

Posted by Arun Gupta on May 02, 2007 at 10:12 AM PDT #

I looked in the Appearance Settings, all that I can see is: - Windows Vista Basic - Windows Standard - Windows Classic - High Contrast White - High Contrast Black - High Contrast #2 - High Contrast #1 No Windows Aero. ( I have recently reinstalled Windows Vista Ultimate and the problem is still the same ) Thanks for your help.

Posted by Charbel Saad on May 05, 2007 at 09:51 AM PDT #

Charbel, You cannot have aero experience with a 915/910 chipset. These are XPDM and Aero tech. needs WDDM.... see intel site for details.

Posted by Karthik on May 06, 2007 at 02:16 PM PDT #

Well thank you for taking some time to answer my question, but I'm a bit ignorant about a notebook hardware. So, if you can just tell me what should I do to run Aero on my VAIO Notebook. If it includes upgrades or whatever, just if you can give me all the details. And thank you again.

Posted by Charbel Saad on May 06, 2007 at 11:19 PM PDT #

you cannot run the aero theme on the 915 chipset, which a lot of laptops upgrading from xp to vista are using. you can't upgrade the hardware either. my toshiba is the 915 chip as well and pretty much you're stuck unless you want a new laptop.

Posted by mbdtech on June 28, 2007 at 02:05 PM PDT #

hi i have a intel pentium d 3.0 ghz ,x1550 radeon pci graphics card and 2.0 ghz ov memory i did have aero on my pc but now it seems to have gone lol i look on my personilization window but all it says is basic it seems to have disappeared any ideas of how i can bring it bck with out a full reinstall. thx gareth.

Posted by gareth on July 29, 2007 at 09:56 AM PDT #

My aero dissppeared aswell so i removed the graphics driver from device manager and then rebooted and reinstalled the driver again - All is working :) Regards digital_sc4rz

Posted by digital_sc4rz on July 29, 2007 at 10:48 PM PDT #

Hi,iv been having a problem with my aero ,As i'am using an Asus A7VT;previously i had to format my PC due to a nasty Jeffo virus.I formatted my PC and upgraded from xp to Vista Home Premium.When i did i lost many thing such as sound and graphics device.I re-installed my Soundcard! But i did find a Graphic device but it didn't support Aero i have been looking all over for a graphic device which can be compatible with my PC and Vista Home Premium. My Asus A7VT Terminator 1 A7VT CPU AMD Duron & Athlon XP 3000+ (Thoroughbred / Barton) AMD Sempron (FSB333 only) 333/266/200 MHz FSB Chipset North Bridge: VIA KM266 Pro South Bridge: VT8235CE Memory 2 x DIMM DDR333/266/133 Support max. 2GB Expansion Slots 1 x PCI 1 x AGP 4X Graphics VIA UniChrome Graphics Integrated IDE 2 x ATA 100 S-ATA N/A LAN 10/100 Mbps Audio ADI AD 1888 6 Channel Codec Dimension (mm) W x H x D 181 x 275 x 300 Drive Bays 2 x 3.5" 1 x 5.25" Front Panel 2 x USB 2.0 1 x Microphone 1 x Headphone Rear Panel 2 x USB2.0 1 x Line-in/Line-out/Mic-in 1 x PS/2 Keyboard 1 x PS/2 Mouse 1 x Parallel Port 1 x D-sub (VGA Out) 1 x Game / MIDI 1 x RJ45 LAN 1 x Serial Port Power Supply 165 W (PFC/none PFC) O/S Support Window 2000/XP Key Features TriOptix Form Factor Swivel Design PLEASE HELP MEEE!!!

Posted by Sim on August 03, 2007 at 01:37 AM PDT #

hey when i first bought the notebook i had that start + tab option which enables the 3d flip, somehow i think i played with the settings and i no longer have the flip thingy, someone help me please, i very used to my previous keyboard which position is now currently in the position of my start and tab.

Posted by nix on September 17, 2007 at 10:22 PM PDT #

Please Help!

Ive updated my PC to Vista ultimate but I still cant get the glass effect.
When the update was running all windows had the effect, but now i just dont have them.
Please help! I have no idea what im doing and Im sooooo not up on technical issues and jargon

Posted by Claire on September 22, 2007 at 01:17 AM PDT #

hi everybody,
i have faced the same problem.
to have AERO feature requires heavy graphics card with minimm 128Mb RAM(in the graphics card). also some motherboards support vista but unable to support AERO.If the hardware requirement are macthing then download the latest driver from its respective website. before installing this driver make sure that all the previous video drivers are removed and disable antivirus. then you should insall the driver.
Am sure this should work ! ! !

Posted by darshan on November 08, 2007 at 08:14 PM PST #

hey guys, ive got the hp pavillion dv6000 and when i first bought it ..i had those little window previews...i dont have them anymore though...and i tried to enable aero by going personalize->window colour & appearance ->windows aero.. can anyone help me to get the cute previews back :P ?

Posted by bob on November 14, 2007 at 08:58 AM PST #

Im having the same problem as guy above. I just got a HP Pavillion. It started with it (which seemed to be great). I did a full system update, and its gone. It's not anywhere to be found. Even did a whole sysyem scan.

Any help?

Posted by charlie on December 08, 2007 at 11:15 AM PST #

In Device Manager, I can see that i have a WDDM chipset. However I seen to have the similar problem of getting the old style display properties when i click "Window Color and Appearance". Windows Aero is not in the list and I get Windows Vista Basic, Windows Standard, High Contrast...etc. Anyone else have this problem or a solution? Thanks

Posted by Wayne on December 09, 2007 at 04:27 PM PST #

Hello,

If you have the right hardware go to Control Panel, then Administrative Tools, then select Services.

Now make sure that the following are set to Automatic Startup:

Desktop Window Manager Session Manager
Themes

And then try the instructions involving the Window Color and Appearance module.

Regards,

Systems Engineer
Contractor - TKC Communications
GRD G6 .NET Operations - Baghdad, Iraq

Posted by PCO-IRAQ.NET guy... on January 06, 2008 at 09:23 PM PST #

"PCO-IRAQ.NET guy" great....I have been searching for the answer on the web for sometime. Your tip really worked!! Somehow my "Theme" service was set to Manual due to which, Windows Vista's Aero interface was disabled. Starting the Theme services fixed the problem.

Posted by sanj on January 13, 2008 at 09:20 PM PST #

My Compaq came with Windows Vista Home Premium and with that I had Windows Aero. I accidentally turned Aero off by selecting a different appearance for my desktop and now cannot turn it back on. I have tried everything mentioned on this site as well as messing with the registry and nothing is working. If anyone can help with my problem that would be great!

Posted by Brock on February 19, 2008 at 07:41 AM PST #

If all of the above does not work for you then make sure that you have 32-bit color selected in display properties.

Posted by funkmasterkiss on February 28, 2008 at 10:29 AM PST #

[Trackback] It took me months to convince my manager that I need a new laptop. Then it took me a few more to convince

Posted by Mark's Windows Server Blog on March 18, 2008 at 09:50 AM PDT #

i have vga>nvidia geforce 2mx>64 MB
i have installed vista on my pc, but aero theme no active,,
i try to update my driver of vga, but windows tell me that my driver is older than driver on package vista,,
can you tell me how to enable aero the on my pc?
or maybe you know about driver that must i install?

Posted by Syainal on March 22, 2008 at 09:57 PM PDT #

nothing

Posted by guest on March 31, 2008 at 09:13 PM PDT #

Wayne, you're a lifesaver. It was more of an annoyance than anything with it not working, but your instructions solved everything after a week of searching for solutions.

Thanks so much.

Posted by Jack on May 11, 2008 at 02:47 PM PDT #

hey all,

i had the same problem with my compaq 6510b and i have now figured out that somehow aero seems to have a problem with an external monitor... as soon as i disabled "extend my monitor blabla" i was able to select the aero style again... don't know if this is a general external monitor problem or if vista has problems with external monitors having a higher screen resolution than the notebook (which mine has)

Posted by bsebear on June 26, 2008 at 09:34 PM PDT #

Hi I have an Intel E6600 2.4 Ghz Core2 Duo processor on an Intel 965RY mother board with nVidia 8600 256MB graphic card and 4 GB Corsair 667 Mhz RAM but still i am not able to enable the Aero experience.

is there any problem with my config?

Can anyone please help

Posted by Maverick on July 16, 2008 at 08:58 PM PDT #

right clcik on my computer click amage and then expand display drivers rightclick update driver that what i did and it worked!

Posted by kishan on July 30, 2008 at 06:23 PM PDT #

hi i have the vista basic OS, and i cannot open the control panel at all... whats the problem???

Posted by tanmaya on August 01, 2008 at 10:00 PM PDT #

My son has jiggered with my pc and i have tried the above ie
Go to Control Panel
Select Personalization
Select Window Color and Appearance
Choose Windows Aero in Color scheme.
the theme is not there my pc was running it fine but my son tells me he downloaded an eygipt theme wich installed over aero i tried asystem restore it never came back can you help or any else ..do you know any links that i can go to and download the aero agian i can not reformat i got too much to loose ..or do you know of a program that will restore windows back to default ive tried uniblue and several other programs none of them have worked ..my pc by the way can handle vista..evrything is ultimate compattable ....

Posted by Richard on August 22, 2008 at 01:37 AM PDT #

This Has Really Annoyed Me Okaii I Was Updating My Windows Vista And After all My New Updates Where Installed It Automatically Changed itself To Windows Vista Classic And Then When I Went To The Personalization And Display setting or wateva It Doesnt Have Windows Aero There anymore
Why Is This?
All I Want To Do Is Put Windows Vista Aero Back On But I Cant restart My computer Clean Again I Have Too Many Important Files That Took Me Ages To Get
Plzz tell me how I Can Get It back

Posted by Greg Sleigh on August 30, 2008 at 06:34 AM PDT #

Hi,

I had the same problem that my Aero theme was not there in Personalization And Display setting.

what i did was reinstall my display drivers and after that it was there.

try reinstalling ur display drivers and see if it works for u as well

Posted by Maverick on September 14, 2008 at 12:27 AM PDT #

good

Posted by ANANTH on October 09, 2008 at 07:51 PM PDT #

@PCO-IRAQ.NET guy.. Awesome!! That was exactly my problem!! Solved now :) Thanks a lot..

Posted by vishwa on October 16, 2008 at 05:06 AM PDT #

Hi I have a windows vista enabled pc but having problems with the 3D function.

I can use the 3D function if I click the shortcut on my desktop but cannot use it using the keyboard shortcuts not sure what that is.

If anyone could help I would be more than grateful.

Posted by Maria on October 21, 2008 at 11:27 PM PDT #

Hi pros. My HP 520 laptop is using Mobile Intel(R) 945 Express Chipset Family
but cant display the Aero theme.
I'm using window vista home premium.
Thanks for ur helping.

Posted by Duc Nguyen on November 01, 2008 at 01:33 AM PDT #

I fixed mine by checking the display settings and changing the colors from 16 bit to 32 bit. To everyone who is having this problem, try and check your color.

Posted by Erika Weavers` on November 18, 2008 at 09:16 AM PST #

tengo un vaio VGN-FJ250P pero con vista no tengo posivilidad de aero tengo 2 de ram procesador intel centrino de 1.73 100 de disco duro tarjeta de video familia mobile intel(r)915gm/gms/910gml express chipset(microsoft corporation xddm) de 128 mb no soy muy experto en el tema digame porfavor que tengo que hacer gracias

Posted by william on November 21, 2008 at 03:07 PM PST #

hey when i first bought the notebook i had that start + tab option which enables the 3d flip, somehow i think i played with the settings and i no longer have the flip thingy, someone help me please, i very used to my previous keyboard which position is now currently in the position of my start and tab.

Posted by BATTERY on November 26, 2008 at 12:59 PM PST #

okay.. i went through everything on this page and every thing on all microsoft help formus... nothing at all worked... just a lot of running around.... BUT... i figured out what casued my aero ( that had been running for months, but i turned off to not be able to be turned on again)

allacation of RAM... i have 4 gigram.. but wanted games to run faster so i allicated priority to suit that... BUT in doing that i now didnt meet the basic requierments to run windows aero.. soon as i changed it back the aero option was back in color scheme... also i should add, any one using a program called "tweakVista" thats most likely your problem, try and change all settings you changed through that program back to what there supposed to be.

Posted by Liam Moron on November 26, 2008 at 01:28 PM PST #

"PCO-IRAQ.NET guy" great....I have been searching for the answer on the web for sometime. Your tip really worked!!

Thank you

Posted by guest on November 29, 2008 at 02:25 AM PST #

pco-iraq's advice works. If the Themes service is already on Automatic (like mine was), restart it. That's what did it for me. Also, the quickest way to get to Services is to type services.msc in the Run box. And thanks, pco-iraq for serving our country in a very dangerous place.

Posted by david on December 08, 2008 at 06:40 AM PST #

@Erika Weavers
@PCO-IRAQ.NET guy

The original writer of this post and above 2 guys solve my problem. Thank you. :)

Posted by Kashif on January 03, 2009 at 08:51 PM PST #

for some laptops (small inch) the display color depth is set to 16 bit after some updates, so some had it working when they first bought the laptop and now they dont. so check the color depth in display settings and change it to 32 bit, works like a charm, a lot of thanks to BROCK, thanks man

Posted by pkaras1 on January 06, 2009 at 01:16 AM PST #

you need to go to control panel admin tools then services enable themes make suits ticked then go to themes and enable aero all the crap above is wrong ...after much searching this worked for me ...

Posted by rick on January 06, 2009 at 11:20 AM PST #

you need to go to control panel admin tools then services enable themes make sure that themes is ticked then go to themes and enable aero all the crap above is wrong ...after much searching this worked for me ...to get to themes right click on desktop select personilse then theme

Posted by Rick on January 06, 2009 at 11:23 AM PST #

thanxxxxxxxxxxxxxxxxxxxxx alot

Posted by Malak from KSU on March 09, 2009 at 05:14 PM PDT #

PCO-IRAQ is a genius!

Posted by FINALLY! on April 03, 2009 at 06:43 PM PDT #

i own a Emachine T3604 machine
that ran Windows Vista Home Premium
it included Intel R Graphics 845 graphic card
and it would crash the system
because I used Aero Theme
now I own a Compaq Presario SR5601 PC
AMD Athlon Processor PC
and it has Windows Vista Home Premium
and it runs good because it has one gig of memory

Posted by MIKE MELVYN on April 20, 2009 at 01:22 AM PDT #

bad

Posted by guest on April 30, 2009 at 11:03 PM PDT #

Go to Control Panel>Personalization>try either mouse or colorization, because the aero is usually under mouse as it is the mouse that is using the aero. Also watch your DPI if playing games and make sure that you don't have any background when you play or install a game, makes a mess of everything.
Hope it helps. Vista is a very easy program to use, and I find I don't make as many mistakes as I did with XP's jargon. Vista is pretty straight forward. You want to turn your DPI down if you want to play games. I have my mouse on aero right now, nifty little colouration so I can find the darned thing LOL :)
Nanette

Posted by Nanette on June 22, 2009 at 10:37 AM PDT #

hi i have a problem with aero i dont no how 2 switch it on or where to find it the computer i have is windows vista home basic could some one please help me to get it turned on plz step by step thanks

Posted by kelly on July 06, 2009 at 08:47 AM PDT #

hey thanx..i fixed mine problem..thanx alot

Posted by nitesh on July 07, 2009 at 01:48 AM PDT #

guys
right click desktop.
click personalize.
click Windows Color and Appearance.
There should be a box next to 'enable transparency'. If it isnt checked, check it.
Hope this helps =D

Posted by hey on July 07, 2009 at 05:05 AM PDT #

Hey all. When i bought my Toshiba, i played around with a few settings and got Aero running. Yesterday i formatted my laptop and now it's gone. I don't remember what settings i had done, could someone please help me?? SPECS > 1.9 Dual, 1GB RAM, 250MB video card. In my windows experience index, the rating says 1.0 due to gaming and graphics, how may i change that?? Please reply me on my email if possible rushil_s_shah@hotmail.com .
Thanks.

Posted by Rushil on August 07, 2009 at 06:30 AM PDT #

hi i have a problame i'm using vista ultimate
my machine have cpu PM 1.8GHz RAM 3GB and vga 128 but it not earo i try so many trick but it not work

Posted by raksmey cambodia on September 10, 2009 at 07:03 PM PDT #

Thank you! simple... Changed display to 32 bit and then went to appearance and Windows Aero was there! Working again

Posted by relieved on April 21, 2010 at 06:43 AM PDT #

Post a Comment:
Comments are closed for this entry.
About

profile image
Arun Gupta is a technology enthusiast, a passionate runner, author, and a community guy who works for Oracle Corp.


Java EE 7 Samples

Stay Connected

Search

Archives
« April 2014
SunMonTueWedThuFriSat
  
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
   
       
Today